3

I know this has been discussed quite a bit, and I have tried all the answers I can find to little avail. So I may have something new. Here are the specifics:

New Mac Mini from late 2015, installed and worked great for a year. Somewhere along the line we upgraded it to Yosemite, no problem. WiFi connects to a Technicolor TC8305C cable modem in the next room with Xfinity service, great speed. It's a 2.4Ghz wireless.

Then suddenly it's waking up to no WiFi. Turning WiFi off and on sometimes fixes it, sometimes not. We upgrade to El Capitan, problem remains.

We have tried:

  • WiFi off and on again
  • WiFi off, go to sleep, wake up, WiFi on again
  • Trashing all the network prefs and restarting
  • Creating a custom location
  • Resetting the router
  • Zapping PRAM
  • Resetting SMC
  • System Preferences, Energy Saver, Battery Power, uncheck “wake for network access”
  • System Preferences, Network, Advanced, TCP/IP, Configure IPv6, switch to “Link-Local only”
  • System Preferences, Network, Advanced, Hardware, MTU to 1450 or 1400
  • We've tried with and without specifying DNS server addresses
  • We've run MalwareBytes and got a clean report.

Most of these things have worked a few times, more often they do nothing. Sometimes it just connects when we aren't even doing anything.

When it works, it works great. Speeds upwards of 40Mbps. WiFi signal is strong with RSSI at -47 to -49 dBm. The single to noise ratio as indicated by the Wireless Diagnostic utility is fine. The Windows 7 computer on the same desk works absolutely fine at all times.

When it does not work the computer can see all the WiFi networks from nearby apartments, no problem, with good signal strength. You select the right network, put in the password, and it says "XXXX could not be joined".

This does not seem like a hardware problem. It doesn't seem like a RF interference problem. It's just refusing to work sometimes, and I've reset everything the internet can tell me how to reset.

Any ideas?

  • UPDATE: we called ComCast, long story short they said "if your router is over a year old get a new one." We were using their router, so the swap was free. The new one has 2.4 and 5 gHz WiFi. Initially I tried the 2.4 gHz, once, and it didn't work. Tried the 5 gHz and it worked immediately and hasn't failed in five days. I'm hoping the problem is solved, but all comments still welcome, just in case. We also bought, but did not install, a WiFi-ethernet bridge, so that's another thing we might try if we get any more trouble. – Andrew Walters Feb 28 '17 at 20:37

You must log in to answer this question.

Browse other questions tagged .