14

I would like my MacBook (on El Capitan) to dim the screen before going to sleep, so that I can hit a key to keep it unlocked if desired. Currently, there is no way to keep it from locking if it's started to turn off the screen.

Any thoughts?

10
  • you could use a hot corner to keep it from going to sleep...? – Mr. Kennedy Feb 9 '17 at 16:15
  • That might work, but I'd still like it to lock itself, in case I walk away from the computer without locking it. – Josh Johnson Feb 9 '17 at 16:17
  • offset the screen saver and sleep... ? – Mr. Kennedy Feb 9 '17 at 16:18
  • 2
    My MacBook dims the screen before sleep exactly like you suggest. I had no idea it was possible to remove that feature, let alone to turn the feature on. I have the ‘Require password after sleep’ setting on too. Interesting question! – grg Feb 9 '17 at 17:08
  • 1
    Anyone know how to reproduce that "Automaticlally dim display before sleep" in the Automator? I don't have any experience with Apple scripting. – ardavis Feb 9 '17 at 17:38
9

…so that I can hit a key to keep it unlocked if desired. Currently, there is no way to keep it from locking if it's started to turn off the screen.

It sounds like you don't need the old dimming action so much as you need a delay on the password lock following sleep or screensaver.

Open "System Preferences → Security & Privacy → General", and change the "Require password … after sleep or screen saver begins" dropdown from "immediately" to "5 seconds" or "1 minute" or longer even.

Screenshot

0
2

There's a free app called Caffeine which prevents it from going to sleep at all. You can activate it indefinitely, or for a particular period of time. I use it all the time.

http://lightheadsw.com/caffeine/

1
  • 4
    I don't want to totally disable it from going to sleep. I still want it to lock/sleep after a certain period of time, but have a 'warning' of sorts, which would allow me to press a key or move the mouse to keep it awake for longer. – Josh Johnson Feb 9 '17 at 17:06
2

I called Apple about this and they confirmed that it's a 'feature' of High Sierra and told me there is no way to get it back. I do remember the option to slightly dim the display was there with previous versions but it's gone now and it will just go dark without warning. I think my iMac at work doesn't do this even though they are on the same version so it could be tied to some other setting. I will look into it Monday and come back.

EDIT: I tried this on my work iMac and it does indeed still dim the display before going to sleep. I cannot find an option for it anywhere, so maybe Apple made it so that notebooks can't do that while desktops can? Both computers are running 10.13.4

0

This is a very interesting question and the given answers were enough in my case the first time I read this months ago.

But since the 5 seconds Security Setting does not quite satisfies me I wanted to look for a solution again

I recently found out this command pmset -- manipulate power management settings as explained by the manual man pmset .

Since I'm not sure about its use I tried to read the man(ual) and to better understand it I've even found out this article online but I'm not yet sure which is the corresponding setting for the old Snow Leopard 'slightly dimming feature'.

Cristian Moisei's answer is indeed interesting too, so I decided to compare both my systems by simply running this example showed inside the man pmset

pmset -g

 Prints a snapshot of battery/power source state at the moment.

This is the results from my Snow Leopard (10.6.8)

Active Profiles:
Battery Power       -1
AC Power        -1*
Currently in use:
 hibernatemode  3
 halfdim    1
 lidwake    1
 acwake     0
 womp       1
 sleep      0
 disksleep  10
 sms        1
 hibernatefile  /var/vm/sleepimage
 ttyskeepawake  1
 displaysleep   3

And this is the results from my El Capitan (10.11.6)

Active Profiles:
Battery Power       -1
AC Power        -1*
Currently in use:
 womp                 0
 halfdim              1
 sms                  1
 hibernatefile        /var/vm/sleepimage
 networkoversleep     0
 disksleep            10
 sleep                0 (sleep prevented by AddressBookSourceSync)
 hibernatemode        3
 ttyskeepawake        1
 displaysleep         3
 acwake               0
 lidwake              1

I've not yet found a solution so this cannot be defined as an answer, more like a lead.

But if you can check what's your settings maybe we could figure this out.


I'm quite a noob and sorry for my english, not a native speaker.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .