On the new macbooks with the Touch Bar, what keyboard shortcut can be used to mirror displays?

On Macbook Pros without the touchbar, the keyboard shortcut for mirroring displays was Command+F1. This doesn't seem to work on the new Macbook Pro with touchbar - you have to press the Fn key to show the F1, F2, etc. keys, and Fn+Command+F1 doesn't seem to do it.

Here are my current keyboard settings:

Keyboard settings


The new shortcut is Command-Dim Brightness. It even makes sense in the following way:

Assuming that you take advantage of the touch bar, and it displays the system controls instead of the function keys then the hand gesture is exactly the same as before when you would have pressed Command-F1 since the Dim Brightness button is where F1 would be:

enter image description here

The annoying thing is that if you have an application-aware touch bar configuration, then you have to bring up the system controls touch bar configuration first.

This is why, in some cases, the Display Menu (in the App Store) which adds a status item in your menu bar (and includes a Mirror Screen choice) is a good option.

|improve this answer|||||
  • 1
    Awesome, thanks! For future reference, this didn't work for me if I had customized the control strip (even if the Dim Brightness button was in the same place), I had to be using the "Default Set" configuration. – Nick Bartlett Jun 29 '17 at 12:51

Workaround found, works for me, late 2016 MBP 15":

System Preferences > Keyboard > Press Fn key to > "Show control strip"

fn + Command + "screen brightness less" (where F1 would be otherwise) = toggle mirroring

|improve this answer|||||
  • This worked perfectly for me. Thanks. – keithRozario Oct 1 '19 at 14:10

I have the opposite problem.. was lacking a stock option to disable this shortcut!

I've remapped Cmd,F1 to display_brightness_decrement using Karabiner Elements - no need to interfere with other shortcuts!

You can install the key mapping from here: disable_cmd_f1_screen_mirroring by following instructions here: configuration-complex-modifications.

Alternatively, to achieve this manually: you can place the following file in ~/.config/karabiner/assets/complex_modifications/disable_cmd_f1_screen_mirroring.json then activate it via Karabiner Elements:

  • Navigate to Karabiner Elements > Preferences > Complex Modifications > Rules
  • Add Rule
  • Enable your new rule
    "title": "Disable Cmd+F1 Toggle Screen Mirroring",
    "rules": [
            "description": "Disable Cmd+F1 Toggle Screen Mirroring Shortcut (map to display_brightness_decrement), see https://discussions.apple.com/thread/2793101",
            "manipulators": [
                    "type": "basic",
                    "description": "",
                    "from": {
                        "key_code": "f1",
                        "modifiers": {
                            "mandatory": [
                    "to": [
                            "key_code": "display_brightness_decrement"

add rule to Karabiner

|improve this answer|||||

Check out your options at System Preferences > Keyboard, under the “Keyboard” tab. There’s a checkbox there for “Use all F1, F2, etc. keys as standard function keys,” and if that’s on, the keyboard shortcut will be Function-Command-F1 instead.

Visit https://www.macobserver.com/tips/quick-tip/os-x-use-keyboard-shortcut-display-mirroring/

|improve this answer|||||
  • This doesn't work for the new macbooks (MacOS). Updated the image above with my whole Keyboard tab in System Preferences. That option doesn't exist anywhere (that I can find). – Nick Bartlett Feb 8 '17 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .