40

I've found solutions for this problem but they dont seem applicable now in 2017.

For some reason, Google Chrome Helper is using a lot of my CPU and fans are going full blast. I found this link on Apple's site that seems to help everyone but I can't seem to find it on my version of Chrome. I have a MBP running 10.9.5.

They mention to go to Chrome > preferences > settings > show advanced settings > content settings (under privacy). Then click the 'click to play' button under the Plugins section. However, there's no plugins section and so I can't do this to try to fix the problem. I'm using Chrome version 56.0.2924.

I don't have many extensions installed on Chrome (just Webex, Google docs, Okta). I have Flash installed too, which I think is taking some resources but there are times I'm not watching video or using anything with Flash and it's still using 150% CPU.

What workaround can I do with this version of Chrome to make Google Chrome helper from using > 150% CPU?

  • 1
    On Chrome Version 70.0.3538 - it is rather buried but here (and it works CPU down from 29% to nominal) Preferences / Settings / Advanced (at the bottom of screen) / Content settings / Unsandboxed plugin access - it is ON by default. Turn this off so that it reads: Do not allow any site to use a plugin to access your computer. This will kill the helper constantly running. Confirmed in Activity Monitor. TBH, any site still using Flash for video can fek off anyway (main culprit affecting Mac). – Applefanboy Dec 14 '18 at 12:49
  • @Applefanboy, CONFIRMED that your suggestion prevents the helper from running constantly. Thank you! – Michael Sims Apr 23 at 23:25
43

Invoke ⋮ Chrome Menu → More Tools → Task Manager to see what exactly consumes CPU. Because the helper is a black box from the OS' side of view. I personally found a mining extension that way.

6

Chrome, or any modern browser, is not so much directly or itself a problem here. Flash on the other hand is a problem in itself. If uninstalling system-wide Flash and the one that is embedded within Chrome are not an option, you should at least prohibit it from autoplay.

Misbehaving plugins or extensions might play a role too. Those mentioned by the OP are unfamiliar to me. Starting without them might lead to satisfactory results. They are certainly not needed on every site you visit. It may help to use different browsers or different profiles for one browser. One browser(-profile/account) for work, another one to ordinary surfing.

The main fault that drives this resource hog is on the web itself. On really old fashioned sites you will not see so much pressure on the rendering and javascript engines that are demanding so much CPU.

First line of defence against this is to block the grossly overused advertising and user profiling or user tracking that dominates almost every page out there. Any adblocker is of tremendous value here.

Second fault is mostly connected to ads as well but comes with a few additional nasties. Bad design on the pages themselves. That includes javascript abuse, bloated CSS, the Google enforced autoloading of additional content, dozens of cross site requests, big media elements. On most major sites you do not load a web page anymore. You load a bit of content that allows dozens of programs to execute around that.

To soften the resource usage of a browser it is necessary to

  • reduce the number of extensions in the browser
  • block ads,
  • allow javascript only were it's strictly necessary for the core functionality of the sites you visit
  • never to let anything autoplay

Since all these tips not only save your electricity bill and bandwidth everywhere they should also enhance your security and privacy.

So look for these search terms in Google's webstore: adblock, security, privacy and block. (follow the links and use the terms for a personal search in the extensions repository of your browser of choice.)

2

150% seems like an awfully high number, even for Chrome. I'd recommend disabling extensions and such temporarily and seeing if one of them is potentially causing the issue.

If, however, you find that nothing seems to work, you can limit the resources available to Chrome. Limiting the resources provided is pretty easy (provided you're willing to work with a little bit of third-party software.) You can use cputhrottle to limit the usage at the system level (better explained here.)

2

It really depends...none of the answers above worked for me, until I disabled each extension one by one and found that it was the Adblocker. Thank goodness Chrome makes it easy to switch these on and off!

As soon as I launched Chrome, CPU would jump to 240%, before opening up any sites.

Weird thing is that I've had this Adblocker extension installed for at least two years, and it just started happening this past week.

1

Okta seems to be the culprit here (as in the site itself) if I open up my Okta pinned tab then the CPUs spike to 100%+ and if i kill the helper process the Okta site crashes out with the 'Aw, Snap!' sick folder screen

0

For me, it was the Google Mail Offline extension.

0

I recently faced similar issue and discovered that the problem is Chrome browser itself which has trouble handling rich websites (a lot of animations causing frequent screen repaints) on 4K screens. 4K screens compared to regular Full HD screens have 4 times more pixels that needs to be painted on the screen. Because of that a lot of animations requires more CPU power to draw all that on screen.

The same site on Firefox performed a bit better. On Safari it was much better but still far from perfect.

It may not be an answer to OP's question but for sure is one of the factors when it comes to browser's CPU usage in those neat ultra high res screens.

0

A note, after using the Chrome Menu → More Tools → Task Manager trick and finding that you have a background tab consuming high CPU amounts: if you don't want to close the tab yet, it may be enough to do right clickReload, without viewing the tab (leave it in the background).

This keeps the tab handy for when you're ready to deal with it, but prevents Chrome from starting up animations.

-2

Click on "not secure" icon on address bar and block JavaScript.

  • 4
    I feel like these sorts of people have never actually tried browsing without JavaScript. It's not fun, and makes some websites non-functional. – William T Froggard Oct 17 '17 at 9:37

You must log in to answer this question.

protected by Community Jun 8 '18 at 20:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .