4

I'm trying to factory reset an old MBP, not sure how old but somewhere between 2009-2012. Weird things happen when I try to reset it though. I have tried twice and I get this error after download of the image is done, in other words, when the installation is about to start.

I have deleted and repartitioned the HDD, and there are no other partitions except "disk2" - and a partition under it called "Mac OS X Base System Image". I have tried correcting the date in terminal, as it was a couple of hours off. This didn't work. The authentication in the beginning of the download goes through just fine. I have tried searcing for similar issues, but people seem to get errors before the download starts, which the date-fix ultimately corrected.

Tldr; Download of OSX-image finishes, weird error occurs when installation is about to start, then exits, undoing everything.

Any suggestions on what to do next?

The text reads: "An Error occurred while preparing the installation. Try running this application again." error-image

  • I've found the Lion recovery and installation very "fiddlesome" if you can I would upgrade to a higher version of OSx if you cannot, keep trying. For me it took a few times before the download actually worked and I managed to install Lion (few>4). – Deesbek Feb 7 '17 at 3:01
0

I solved it by creating a bootable USB from another Mac with Sierra on it. The MBP works like a charm now!

  • Currently even bootable USB with High Sierra didn’t work. Will try bootable Sierra later. – Franklin Yu Jun 26 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .