I installed ffmpeg 0.8.5 in my Mac OS X Lion 10.7.1 with Homebrew

brew install --use-gcc ffmpeg

It installed without any error. But, now when I run, it gives the following -

dyld: Library not loaded: /usr/local/Cellar/ffmpeg/0.8.5/lib/libavdevice.dylib
  Referenced from: /usr/local/bin/ffmpeg
  Reason: Incompatible library version: ffmpeg requires version 53.0.0 or later, but libavdevice.dylib provides version 52.0.0
Trace/BPT trap: 5

2 Answers 2


Try using:

$ brew update && brew install `brew outdated` && brew cleanup

This script will also help you track down changes on libraries that are needed.

If you those don't work try:

$ brew doctor (check your setup for common problems)
$ brew missing (to check installed packages for missing deps)

brew doctor checks your setup for common problems, brew missing checks installed packages for missing deps.

You can always start fresh (which should take care of all the problems):

$ brew uninstall --force `brew deps ffmpeg`
$ brew install ffmpeg


$ brew update
  • Didn't work for me :( but still thanks for your effort :)
    – Rifat
    Oct 10, 2011 at 21:06
  • I've added a couple more solutions to try,
    – l'L'l
    Oct 10, 2011 at 21:43
  • brew uninstall --force brew deps ffmpeg`` & reinstalling did the trick for me, though it also uninstalled git and the reinstall didn't. Dec 25, 2014 at 10:00

I ran: brew install libav

then after it complained about symlinking: brew link --overwrite avconv

Works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .