2

I want to install Eclipse or Netbeans on macOS Sierra. When I try to run Eclipse, I get an warning that Java 6 is needed. I downloaded the latest version of Eclipse to be sure.

To open Eclipse you need to install the legacy Java SE 6 runtime

So I tried Netbeans:

Netbeans - No JDK found

While at the same time the System settings report that Java 8 is installed and up to date.

macOS System settings for Java

How can I get either Eclipse or Netbeans working on macOS Sierra?

2

You need to install the full JDK version of Java 8 (jdk-8u121-macosx-x64.dmg) rather than just the JRE.

The JRE install does not include the support to run Java programs outside of a browser.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .