1

I've been having trouble with my Mac since I installed Yosemite, where I open an .dmg file, and it would go to the Disk Utility, then I would have to open it from there. My MacBook running Yosemite did not do this, and would give the normal graphic to drag the file over applications to execute it.

Now I've upgraded to Sierra, and I get an alert that says "The document “Example.dmg” could not be opened. Disk Utility cannot open files in the “Disk Image” format". I try to right click the file, but it does not give me an "open with" only an "open" which gives the same error. Again, my MacBook just opens the installer program just fine. I verify the images on Disk Utility, and I get an "operation successful", but the file still won't open.

I am sure there is a way to get round the problem and open the .dmg files, but I would like to adjust the settings so that the installer opens as designed.

  • Your question is unclear: "...would like to adjust the settings so that the installer opens as designed" vs. "Disk Utility doesn't open dmg files". – klanomath Feb 6 '17 at 10:58
  • To clarify, I wanted the .dmg file to open to the installer, the disk utility does not allow this, and 'open with' did not work. I did find the answer to adjust the settings so the installer opened as designed. – Haole Jon Feb 7 '17 at 9:41
1

So, this solves the problem of how to get the file to open. I don't know why the "open with" was not working, but after several hours of trying different search strings in Google, I found this article that explains how to change the default to the disk image mounter instead of the Disk Utility: How to change default apps on the Mac.

Steps are copied below:

  1. Go to the Mac's Finder.

  2. Find the file type you'd like to open with a specific app, and select it.

  3. Click on the File menu and select Get Info.

  4. Expand Open with: by clicking on the triangle to the left.

  5. Select the Open with: menu, then choose the app you'd like to use to open all documents like that one.

  6. Click the Change All... button.

  7. You'll get a dialogue box asking you to confirm your choice. Click Continue.

  8. Close the Get Info window.

Worked like a champ. I don't know how this got changed in the first place (my Macbook did not change), but that is another question.

-1

I had the same issue after updating to High Sierra. I downloaded the program over and over with no changes, all that popped up was that the disk image could not be recognized. I finally downloaded Google Chrome, downloaded the software again and it opened. I then had to go into my security settings when it prompted me to do so and allow the application to be opened anyway sense it was not from an identified developer. I clicked open anyway and BAM problem solved!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .