My log-in screen appears with question marks instead of the usual text. (See screen shot - I have removed my log-in name from the picture). I am using MacOS Sierra 10.12.3 on a MacBook Pro (early 2011).

  • What language text encoding are you using? Feb 6, 2017 at 7:57
  • English (Australia)
    – dt666
    Feb 7, 2017 at 22:18
  • Booting in Safe Mode gives the correct characters
    – dt666
    Feb 13, 2017 at 22:01
  • The issue is in your text encoding, let me post an answer soon Feb 13, 2017 at 23:38
  • This happens to me after my mac get somewhat slow and unresponsive
    – ɹoƃı
    Jun 9, 2017 at 14:53

2 Answers 2


Try going to Applications/Font Book/ and do File > Restore Standard Fonts and restart.


The issue is due to missing fonts. (Where the system picks a poor choice to substitute for the “missing characters”). If you use font management software, be sure to reinstall or re-enable the system fonts.

1. Run validations with Font Book

Launch Font Book and press command-A to select all fonts. Then from the "File" menu select "Validate Fonts" and wait for the results in the font validation window. Keep in mind that even though you may find minor problems with your current fonts, its best to follow the saying "if it's not broken then don't fix it", and leave well-enough alone unless you're experiencing problems.

2. Clear the font cache

In OS X, fonts are handled by the Apple Type Server process, which stores commonly used fonts in a cache for quick access. If there is corruption in this cache then you may experience a variety of troubles. To clear the cache, in pre-Leopard versions of OS X go to the /Macintosh HD/Library/Caches/ folder and remove the "com.apple.ATS" file. After doing this, restart the system.

For OS X 10.5 and later, you cannot easily access the user and global font caches, but you can use Apple's "atsutil" terminal command to manage the ATS process. Open "Terminal" and enter the following commands to clear the user (or global) databases and restart the server:

atsutil databases -removeUser atsutil server -shutdown atsutil server -ping

NOTE: Use "sudo atsutil databases -remove" instead of the first command to remove the database for all users.

3. Avoid older font formats

If you can, avoid ".dfont" and "Type 1 PostScript" fonts. This suggestion may depend on the requirements for various programs, but if you have an older font suite that you are thinking about installing, it may run into problems with newer programs so you might consider getting an updated version of the suite before installing. Granted you can always try, but there is the potential that older font formats can cause problems so we recommend you stick to the more modern ".ttf" and ".ttc" fonts.

4. Manually clear out duplicates

Font Book has an option to "Resolve Duplicates" (available in the "Edit" menu), but this is limited in functionality and may not remove the specific font duplicate which you desire to remove. As such, the best approach to managing duplicate fonts is to do it manually (tedious, but effective if done correctly). In Font Book, you can use the "Show Font info" option (command-I) to see information about a selected font, and especially where the font is located on your system. Doing this for your duplicate fonts will allow you to select which one to remove, either by removing it from its font folder, or by right-clicking it and selecting "Disable".

From: https://www.cnet.com/news/font-problems-and-management-in-os-x/

  • I would delete the part about text encoding, which has nothing to do with this problem. It's a font issue. Oct 4, 2017 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .