I'm trying to execute a shell script as a cron job. The problem is that my script needs to be run as a super user. I tried it with just writing sudo infront of the command in my crontab file, but it didn't work.

3 Answers 3


Cron is not in any way deprecated, but LaunchD has more versatility and is used, and actively maintained/supported by Apple. Their best practices guide is here

LaunchDaemon jobs(versus LaunchAgents, which take on a users id) run in root's context without needing to enable the root user. All that is required is a properly formed XML file(you can just copy-paste pre-existing ones in /Library/LaunchDaemons, substituting your script for the ProgramArguments with the applicable schedule keys) with the proper ownership/permissions. An older writeup can be found here: afp548's launchd-in-depth article


It's a security risk, but you can enable the root user and run the command in root's cron. Alternatively, have you tried using sudo -s to get a "root shell" and making root's cron that way. Depending on your OS level, you might not need to have root enabled as a user for it's cron to run.

If you want to do it without enabling the root user (which is not really necessary in this case), you may (as any administrative user) enter sudo crontab -u root -e to edit root's crontab directly.

  • This should be two answers =1 for enable root, but +1 for the edit crontab as another user
    – mmmmmm
    Commented Oct 27, 2012 at 13:08

Comment "Defaults requiretty" from /etc/sudoers using visudo.

  • And where does the password come from in this case?
    – nohillside
    Commented Oct 27, 2012 at 15:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .