1

While using my Macbook Pro (2012) yesterday, the screen suddenly went black and turned off - instantly. I turned it back on, can see the Apple logo bu the progress bar sticks at around 40%. The MacOS version is El Capitan, 8GB RAM and 500GB SSD.

I tried rebooting while hold CMD + R: I see the Apple logo, the progress bar gets to about 80% then it restarts again. All I get then is a blank grey screen.

Next I tried OPTION + CMD + R: this time it asks for my WiFi network, then I see the spinning globe icon. It finishes downloading files, reboots and again goes back to a blank grey screen.

Tried to run Apple Diagnostics, by holding down D during a reboot - all I got was the blank grey screen. So I googled some more and found that if you reboot, hold OPTION + D then it connects to the internet to run the hardware test. The hardware test completes successfully with no errors, using both the standard and "extended" set of tests.

The next step was to run Verbose mode using CMD + V. I tried to capture this on my camera as it chugged through a load of debug messages. Too much to list out, but I will show what look like errors:

** /dev/rdisk1 (NO WRITE)

** Root file system
   Executing fsck_hfs (version hfs-305.10.1).
hfs: Received 6 orphaned / unlimited files and 8 directories
BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory
Warning: couldn't block sleep during code updates
Warning: proceeding w/o DiskArb

bash: /etc/rc.server: No such file or directory
bash: /etc/rc.installer_cleanup: No such file or directory

fInterfaceSnapshots is missing [ this is repeated 10 times ]

** GPU Hardware VM is disabled (multispace: disabled, page table updates with DMA: disabled, non-contiguous VRAM: disabled)

Airport: Link Down on en1. Reason 8 (Disassociated because station leaving)
Got incomplete channel sequence length 0, should be 16
en1: channel changed to 1
en1: IO80211Interface::postMessage bssid changed

Previous shutdown cause: 3

DSMOS has arrived
in func createVirtualInterface ifRole = 1
IO80211VirtualInterface::createIOReporters p2p0 provider 0
IO80211InterfaceMonitor::initWithServiceAndName(): Unable to get fProvider
Unable to create IO80211InterfaceMonitor
  • 2
    I assume you tried resetting SMC and NVRAM? – n1000 Feb 5 '17 at 10:34
  • 1
    Did you run Apple Diagnostics? It sounds like faulty hardware like RAM or GPU... – n1000 Feb 5 '17 at 10:35
  • The nvidia GPUs of the 2012 MBP are problematic and known to break. So it could be that your Mac crashes when it tries to initiate the dGPU. I guess my next approach would be to try and install OS X on a USB drive and try to boot that (press alt at boot screen). But given that you cannot make it into recovery mode, I fell like this will not work either. Can you get into single user mode? – n1000 Feb 5 '17 at 11:59
  • 1
    What happens when you boot in Verbose Mode (Cmd-V). Have your camera rolling to capture what gets output when it crashes. – Allan Feb 5 '17 at 13:00
  • The MBP has been to an Apple service centre. The GPU has failed which means the entire logic board needs replacing. Unfortunately due to the age of the MBP, Apple consider it to "vintage" and no longer produce spare parts. I can't actually find anyone with replacement logic boards in stock, so it looks like its going in the bin. I'm really sad. – rf_wilson Feb 10 '17 at 14:11

You must log in to answer this question.

Browse other questions tagged .