5

I was able to freely scroll forward and backward in time. I can only go forward via the arrow keys one page at a time now. No idea why this is happening.

I tried a workaround at one point by clearing my calendar (methodical removal of plists, etc...) then restoring it from iCloud. After that restoration it didn't work. Next day scrolling worked. Day or two later, scrolling calendar stopped working and still doesn't.

3

Put two fingers on the page and move it to the left or the right, stop when you want. It is still there. The arrows move a page completely, set to day, week or month when you want to use the arrows.

5
  • Hey, it's working, but why? Huh? What did moving fingers left/right do to make it work again? – clearlight Feb 4 '17 at 9:28
  • I'm using a magic trackpad, not that that has anything to do with it. – clearlight Feb 4 '17 at 9:28
  • @clearlight What did you do before? It's always been two fingers? – grg Feb 17 '17 at 10:09
  • @grgarside 1st & 2nd time it happened and I tried the suggestion, 2 finger swipe worked. Last time it happened it didn't. It was stuck. Next day I checked calendar and it was working fine again. Don't know why. – clearlight Feb 17 '17 at 16:56
  • @grgaside - I misunderstood you question: Hey, I'm a power user, I know the appropriate gestures for the trackpad - the middle finger! Just kidding! Mine isn't a "How do I scroll using trackpad?" question by a noob, the two finger movement "Lexs" described were RIGHT/LEFT movements to UNLOCK wedged vertical movement, which worked for me only once or twice... e.g. after doing r/l swipe, the 2-finger up/down scroll worked again. But there is no obvious logical reason nor indication that one would have to swipe right/left to release locked/wedged/broken vertical scrolling. – clearlight Feb 17 '17 at 22:31
2

There seems to be a fundamental bug in the calendar. I was researching this yesterday, came across your question. Didn't understand LexS's answer, didn't want to go through the hassle of deleting plists.

The next morning, I still have this page open on one monitor and my calendar open on the next. I go to scroll the calendar and... tada, it scrolls fine.

The only thing I can think that I did was move a repeating item from the day before the current day to the day after the current day. Maybe that's what causes it? Who knows.

2
  • I've found it intermittent. Don't know a reliable trigger or solution yet. – clearlight Feb 17 '17 at 10:06
  • I've found that putting mac to sleep and waking it up restores these gestures. The similar thing happens in mail where you can not swipe given mail left to archive it. – Petr Újezdský Jan 17 '19 at 12:29
1

I use an iMac, MacAir, & iPad. After upgrading the iMac to Sierra, the calendar scrolling feature on month & year view stopped working. I called Apple and 2 reps said that this feature no longer exists in Sierra. I'm not upgrading my other Apple products. Apple Reps suggesting entering feedback about the loss of function at www.apple.com/feedback. Rep said if enough people send feedback, then they are more likely to consider bringing the feature back.

2
  • I'm not sure what version of macOS Sierra you're running, but on all the Sierra machines I use there's no issue with Calendar scrolling. I suspect and bugs have since been ironed out. – Monomeeth May 29 '17 at 22:07
  • I'm using macOS Sierra 10.12.5 and haven't noticed the scrolling problem I posted the question about for awhile. Clearly it is supported for at least this version of Sierra. – clearlight Jun 22 '17 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .