Apple Mail asks for Google login on a daily basis. This happens to both my personal and work gmail account. I tried generating app specific password but when i go to preferences -> account information: there is no field for a password.

This has been happening only since I have upgraded to 10.12.4.

I couldn't reproduce the issue easily - not until the next prompt for password shows.


I tried deleting and re adding the accounts. It did not fix the issue. Worse, I could not log back into my account this time the google login prompts. It was stuck at a gray screen after entering the password.

However, updating to the latest public beta just now resolved the issue.

  • 1
    we do not discuss betas. see the terms of use.
    – LexS
    Feb 4, 2017 at 9:49
  • 2
    @LexS Discussions about public betas are on-topic, see meta.apple.stackexchange.com/questions/2707/…. The FAQ has been updated to reflect that.
    – nohillside
    Feb 4, 2017 at 10:14
  • Accounts are managed in System Preferences nowadays, not in Mail Preferences. You should be able to change the password there.
    – nohillside
    Feb 4, 2017 at 10:15
  • 1
    Same problem here (also started when upgrading to 10.12.4 beta) so I suspect this is a bug.
    – Martin
    Feb 4, 2017 at 16:40
  • yep same here... waiting for new beta :( Feb 7, 2017 at 5:15

2 Answers 2


I am not sure what else you've tried so far, so I'll begin from scratch:

Disable two-step verification

In the past, I've found that two-step verification caused issues between OS updates. Use Google's website to disable two-step verification for your accounts. You can reenable it later. If you aren't using two-step verification, continue.


  1. Completely remove the affected accounts: System Preferences > Internet Accounts > select account > click minus icon
  2. Add the accounts again. You should see a Google-branded login frame in the window.

If you are able to do this, continue monitoring for the issue. If you've already tried this, please update your answer with what is currently happening and the steps you've taken.


Installing public beta 10.12.4 version v2 resolved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .