11

Good day! iMessage on my mac fixes my typos as I type despite the fact that I've disabled spell check in settings.

Here is how it looks:

iMessage

Preferences

Is there any way to fix that? Thank you in advance.

2
  • That's not actually fixing anything, just telling you it doesn't recognise the word. If it had fixed it, the word would be a) spelled correctly & b) underlined in blue dots, not red.
    – Tetsujin
    Feb 4 '17 at 6:52
  • Yes, you are right, but how do I show you fixing as I type unless I do some sort of a screencap? See answer to my question below. Feb 4 '17 at 9:29
23

In Messages, go to Edit > Spelling and Grammar and make sure the items for automatic correction are UNchecked.

4
  • 1
    also completely quit the Messages app after changing the settings, then restart it.
    – LexS
    Feb 4 '17 at 12:14
  • 4
    Wow, they should really use the global settings under System Pref > Keyboard. I foresee more idiosyncrasies like this as they move more phone apps in to osx 🤦🏾‍♂️
    – prasanthv
    Mar 26 '19 at 15:43
  • 3
    @IvanAracki You missed the point. In Catalina, just like earlier MacOS versions, the setting is in BOTH places, and you may have to check both of them to get the result you want. Dec 10 '19 at 12:54
  • Also accessible in the context menu by right clicking the text field
    – LeZuse
    Jan 12 '21 at 14:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .