I'm trying to upgrade to xcode 4.1, but I it's not working as I expect. I am a registered iOS developer, so I downloaded the (huge) installer. When I double click, it appears to launch, but then it stalls -- nothing happens. There's no installer window with buttons to click, etc. I'm sure there's a better way to do the installation from the terminal and see what's really happening. What do I try next?

Also, I'm wondering if anyone has made this work with OSX 10.6.8 yet, as there were some descriptions of the installer crashing on the dev forums. No answers there as of yesterday.

Update: tried so far-- Note: This is the correct version of xcode 4.1 for 10.6 (snow leopard) Not the one from the mac store, which is only for 10.7.

  • I removed the previous version of xcode (was 3.2.5) using /Developer/Library/uninstall-devtools --mode=all.

  • Looking at the syslog, I see a couple of errors that might be causing trouble: Firstly, when I shut down last night it shows Macintosh DirectoryService[11]: BUG in libdispatch: 10K549 - 1960 - 0x10004004. Secondly, this is showing up repeatedly: Macintosh com.apple.launchd[1] (com.apple.SystemStarter): Failed to count the number of files in "/System/Library/StartupItems": No such file or directory

  • When I tried the installer again, the syslog reported the above no such file or directory several times, then Macintosh com.apple.launchd.peruser.501[93] (com.apple.coreservices.uiagent[230]): Job appears to have crashed: Segmentation fault and a crash report.

Perhaps something is corrupted in my /System/Library files that is causing it to choke. Any other ideas on suggestions on how to repair this?

Update 2: I never managed to install xcode 4 on my macBook. The root of the problem seems to be that this was one of the earliest models of macBook to use the Intel processor. And XCode 4 doesn't seem to run well on this processor. Someone may have found a work-around by now, but I ended up with a newer computer: late 2009 MacBook Air running Snow Leopard. No problems with xcode 4 installation.

Crash Report stuff: (hopefully the useful bits...)

Exception Codes: KERN_INVALID_ADDRESS at 0x00000000281e9000
Crashed Thread:  2

Thread 2 Crashed:
0   libSystem.B.dylib               0x96032401 sha1_block_asm_data_order + 29

Thread 2 crashed with X86 Thread State (32-bit):
  eax: 0xb02258a0  ebx: 0x93e07a69  ecx: 0x281e9000  edx: 0xb4148629
  edi: 0x85121bec  esi: 0xa1f8b822  ebp: 0xd7deffcd  esp: 0xb02257c0
   ss: 0x0000001f  efl: 0x00010286  eip: 0x96032401   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x0000001f   gs: 0x00000037
  cr2: 0x281e9000

Followed by a long list of addresses that all refer to various files in either /System/Library/Frameworks or /usr/lib/. Several of them have ???(???) in the line. 

The last line is: 
`0xffff0000 - 0xffff1fff  libSystem.B.dylib ??? (???) <2DCD13E3-1BD1-6F25-119A-3863A3848B90> /usr/lib/libSystem.B.dylib`
  • Which one are you using, the one from developers.apple.com, or from the Mac App Store?
    – jmlumpkin
    Oct 10, 2011 at 13:32
  • The one from developers. The one on the app store is only for 10.7, which I'm not running.
    – Suz
    Oct 10, 2011 at 14:21
  • Thanks for the clarification. I wanted to make sure since you are correct, the MAS version won't work on 10.6.
    – jmlumpkin
    Oct 10, 2011 at 17:46
  • Why bother? Anything reason not to update the OS?
    – Shane Hsu
    Jul 30, 2013 at 16:08

4 Answers 4


I'd use Xcode 4.2, as it's the last supported version of Xcode on Snow Leopard. It can still be downloaded from developer.apple.com.


Per Wikipedia, there were two releases of 4.1. One was introduced with OS X Lion, and another was released for Snow Leopard. Perhaps the Lion release requires Lion, and perhaps that's the one you have. I'm not sure how you could tell the difference.

  • Read the WHOLE question, along with the updates. Once you've done that, I think you'll understand that your answer is not very helpful.
    – Suz
    Jul 19, 2013 at 12:10

Try removing the previous version of XCode first (there's an uninstall script in the Dev tools folder), then run the installer. For some bizarre and unknown reason it can get stuck trying to replace the previous version.

If that doesn't work dig into your syslog and see if it's throwing any errors and post back and we'll see if there's something weird going on.

  • This exact problem happened to me yesterday. I uninstalled all traces of Xcode, launched the installer again, and was good to go. Oct 10, 2011 at 14:40
  • OK, I finally got a chance to try it. I ran uninstall-devtools --mode=all. It checked through everything and seems to have cleared off xcode. I rebooted. I tried again. I guess there was some progress -- the icon jumped up and down a lot more before it gave up. I found a binary syslog in /usr/bin. Is that the right place? How do I check if it is 'throwing errors'?
    – Suz
    Oct 10, 2011 at 20:49
  • @Chris can you elaborate on 'all traces of xcode'?
    – Suz
    Oct 10, 2011 at 21:15
  • 2
    I ran this sudo /Developer/Library/uninstall-devtools --mode=all Oct 10, 2011 at 22:16
  • @Suz try going to Applications then Utilities then Console, it'll give you access to the syslog and you can find out where the issue is. Oct 10, 2011 at 22:24

I'm using version 3.2.6 (1761) with no problems. Might be an option for you. https://developer.apple.com/devcenter/download.action?path=/Developer_Tools/xcode_3.2.6_and_ios_sdk_4.3__final/xcode_3.2.6_and_ios_sdk_4.3.dmg

  • He asked especially for Xcode 4.1 and not Xcode 3.2.6
    – Pfitz
    May 5, 2013 at 8:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .