4

I successfully installed Chrome on my Mac. However, when I'm trying to start it the browser icon just bounces in the dock once and disappears. Reinstalling, rebooting Mac and other options found on forums didn't help at all. How to fix this problem?

8

After a lot of investigation, I've finally found the solution (so I decided to put it as an answer here).

You need to open Terminal (Spotlight search - type "terminal") and run the following command:

sudo rm -rf ~/Library/Application\ Support/Google/Chrome

It will remove Chrome user data so use it at your own risk, but at least it helped me to run Chrome on macOS. Other approaches that seemed safer didn't work for me. You need to back up the Chrome folder beforehand if you're worried about losing your data.

7
  • Doesn't this remove all your chrome extension data and session tabs? I don't want to do that. I did nothing wrong and Apple released a horrible update that broke Chrome. Why should I have to suffer and lose data?
    – cameronroe
    Feb 12 '19 at 9:43
  • @cameronroe you can copy the contents of this folder somewhere else before removing it and then see what you can add back so it won't be broken Feb 14 '19 at 17:49
  • Have you run Chrome earlier? Mar 4 '19 at 8:07
  • 1
    You don't need sudo here as everything unde ~ should be owned by the user
    – mmmmmm
    Mar 4 '19 at 10:40
  • This is the worst answer ever. You should have warned that this is going to delete chrome's data. I ran this command and lost all my bookmarks! Jul 19 '19 at 13:51
5

OK. I did not have the Chrome folder under ~/Library/Application\ Support/Google So I just deleted the "Google" folder under "Application Support" and that fixed it!! deleted the Google folder - re-started Chrome and the Google folder and other folders under it got created

3

Other thing is to run Chrome from the Terminal.

$ cd '/Applications/Google Chrome.app/Contents/MacOS'
$ ./Google\ Chrome &
3
  • [1] 61144 [1]+ Killed: 9 ./Google\ Chrome May 6 '20 at 10:43
  • This works for me. Then I can open the Chrome by clicking the app as usual.
    – Arefe
    Aug 23 '20 at 16:38
  • Surprisingly, this... worked :D Jun 22 at 10:48
1

If the above command doesn't work, Open the Spotlight Search (cmd+space), Enter "/Library/Application Support" . Locate the Google folder, Move to Trash. And reinstall Chrome once again

1

Better solution than removing the folder, since we don't know the impact, it to change folder permission.

Open Terminal and use command below:

sudo chown -R $(scutil <<< "show State:/Users/ConsoleUser" | awk '/Name :/ && ! /loginwindow/ { print $3 }') ~/Library/Application\ Support/Google

This is basically same solution few other folks are mentioning above, but they are recommending the GUI way.

PS: your password (administrator privilege) will be required.

1
  • My editing solved exactly this problem? Why are you editing it again? If you are currently root in the terminal and enter $USER , your user name will not appear but root. So the directory would be changed to root. Apr 22 at 19:41
0

In my case the problem was solved by repairing folder permissions in the ~/Library folder as follows:

  1. Using Finder, navigate to ~/Library using the ⌘⇧G (Command+Shift+G) command
  2. Open the folder info dialog
  3. In the "Sharing & Permissions" section, unlock the lock by entering credentials
  4. From the cogwheel drop down menu, select the "Apply to enclosed items..." action
0

This is what worked for me: https://discussions.apple.com/thread/7494016 Basically you need to give the Google folder admin privleges in the Application Support folder. Like this:

  1. Open a finder window or click on the Desktop.
  2. Hold down SHIFT+COMMAND+G (⇧⌘G) type "~/Library/Application Support". Then click Go
  3. Find the folder named "Google"
  4. Get Info (⌘I)
  5. In the Get Info window click on the lock in bottom right corner Enter your login password (you need to be an admin) and press enter
  6. Click the + button on bottom left
  7. From the drop down click on Administrators Then click on select At the bottom of window you should now see admin Under "Name" To the right of amin click on "read only" and change to Read & Write
  8. Now click on the setting cog and select Apply to enclosed like this

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .