0

I have a WD Mybook Studio 500gb that will not mount. I've tried every possible option in Disk Utility and it see the drive (unlike finder), but won't mount the partition. I also tried plugging it in to a PC and again W10 didn't see the drive, but I could perform diagnostics on it via WD's tool (but no fix in sight).

I did some digging with with testdisk and the data is intact, no errors, I can see the file structure on the data partition etc but the partition map/table has tons of errors and I believe this is the cause of the problem - the data is there but the computer can't access it due to a corrupt partition map.

Here's what I get in terminal when looking at the drive info:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Internal HD             255.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB      disk0s3

      /dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        *500.1 GB   disk2
   1:        Apple_partition_map                         32.3 KB    disk2s1
   2:                  Apple_HFS General DATA            500.0 GB   disk2s3

And the second part for the drive in question:

$ diskutil info /dev/disk2s3
Device Identifier:        disk2s3
Device Node:              /dev/disk2s3
Part of Whole:            disk2
Device / Media Name:      Apple_HFS_Untitled_1

Volume Name:              General DATA
Escaped with Unicode:     General%FF%FE%20%00DATA

Mounted:                  No

File System Personality:  HFS+
Type (Bundle):            hfs
Name (User Visible):      Mac OS Extended
Journal:                  Unknown (not mounted)
Owners:                   Disabled

Partition Type:           Apple_HFS
OS Can Be Installed:      No
Media Type:               Generic
Protocol:                 FireWire
SMART Status:             Not Supported
Volume UUID:              88071423-C35F-3BAA-BEE6-E3A3B3D9948F

Total Size:               500.0 GB (499973603328 Bytes) (exactly 976510944 512-Byte-Units)
Volume Free Space:        0 B (0 Bytes) (exactly 0 512-Byte-Units)
Device Block Size:        512 Bytes

Read-Only Media:          No
Read-Only Volume:         Not applicable (not mounted)
Ejectable:                Yes

Whole:                    No
Internal:                 No

Can anyone help with advice on how to rebuild the apple partition map? I think this can be done with testdisk but I can't seem to fumble my way to the correct answer? by the way, I need to access the data on the drive, not just reformat and repurpose the hardware.

Help!

1

Seems like you need the following: Fixing my external hard drive's partition map

The fact that it's external shouldn't make a difference to you.

What happens when you try to mount it?

eg.

diskutil mount /dev/disk2s3

alex@smiley:~|⇒ diskutil mount Usage: diskutil mount [readOnly] [-mountPoint Path] DiskIdentifier|DeviceNode Mount will mount the volume in the "standard" place (/Volumes), unless an optional mount point is specified.

The error you get should point you to your problem.

  • Thanks. I get this: > Volume on disk4s3 failed to mount > If the volume is damaged, try the "readOnly" option – user7507965 Feb 3 '17 at 17:57
  • Did you try that? diskutil mount readOnly /dev/disk4s3 – Alex Feb 4 '17 at 2:24
  • Yep, still tells me disk can't be mounted. I believe the partition map is damaged to the point it won't mount at all, so I basically need to rebuild or replace, but keeping the actual data intact. – user7507965 Feb 4 '17 at 15:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .