0

I use Lion 10.7.2 and while I was trying to make Bluetooth kext work, I removed a kext named IOHIDFamily.kext from /System/Library/Extensions (SLE) folder but this gave a kernel panic so I copied it back to SLE. However after copying, it kept on giving kernel panic and I noticed that it had owner information like _unknown:_unknown Thinking that it was this false ownership causing the kernel panic

I tried:

# chown -R root:wheel IOHIDFamily.kext

but it doesn't change the ownership neither does it return any error message. I've tried to chown using an app called Path Finder 7 but it didn't even have an option to chown or I couldn't manage to find one.

How can I solve this problem? Thank you.

1

You might try running the chown command on the whole /System/Library/Extensions/ directory from single-user-mode (hold Command-S on boot, or use -s as a bootflag if using Clover/Enoch/Chameleon), or doing the same thing from the Terminal app in your recovery partition. Also make sure you include su or sudo in front of the command, or are logged in to a fully root shell before doing so.

| improve this answer | |
  • Thank you for the answer. I forgot to mention that I tried booting into single-user mode. After single user mode, the keyboard stops responding i.e. I can't input any command. I guess it might have something to do with the IOHIDFamily.kext. That's why I tried to fix the permissions from another Mac using Terminal and the Path Finder. I – Romario Feb 1 '17 at 22:05
  • Ah. In that case you might still be able to restore the system from the Recovery partition (or the Internet Recovery feature) if you can access it. I believe using the "Reinstall macOS" option in either of those will only overwrite system files, so while you'll lose system modifications and have to reinstall any extra kexts you had, your user data should remain intact. – Alison E.E. Feb 2 '17 at 0:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .