1

Sometimes my system (macbook air, mid-2013, sierra 10.12.3) freezes (beachball + can't really click anything although some mouse movement is possible) and doesn't come back to normal unless I reset it. This usually occurred during archiving an app, but today happened when I tried opening extensions in safari preferences.

I've tried running Disk Utility, but it says that the disk is ok. What other diagnostic can I run?

1

It sounds as though your install is corrupted. You may to boot to your recovery parition (Command-R after the chime), followed by the "Reinstall macOS" option. It should only overwrite the core system files and leave your User/User data/Custom apps untouched, but to be safe you should make a Time Machine backup first.

  • Ok, I could do that. I'm just curious - how did you arrive at this conclusion? – Ranza Feb 2 '17 at 10:08
  • Fragmentation. Despite common myths macOS is not immune to it, especially when preforming disk-intensive tasks like archiving or copying large files. If you do this enough the system might hang due to how scattered the files are. For example if Safari it split into 20,000 different parts of the SSD, and 19,500 of those are nowhere near each other, and all 19,500 of those parts are Safari's extensions handler then the system would likely dedicate all available CPU resources to reading all of that data, leaving nothing left to handle the rest of the OS, causing the rest of the OS to lock up. – Alison E.E. Feb 4 '17 at 22:46
  • While fragmentation would not normally be an issue serious enough to cause such a problem, especially with an SSD, the model of MacBook you have has a relatively slow CPU compared to how demanding macOS Sierra is, plus the default CPU is an i5, which unlike an i3 or i7 does not have HyperThreading (it is designed to handle single large processes at a time, not dozens of small ones) making it less equipped to smoothly read from or write to a heavily fragmented disk. – Alison E.E. Feb 4 '17 at 22:55
1

Turns out I did it to myself. I've turned off memory compression some time ago, forgot about it and that caused the issues. In particular I've set sysctl -a vm.compressor_mode to 1 while is should be set to 4 for optimal experience.

It's really hard to imagine how radical the change was. I came from "trauma of opening another youtube video" mindset to "let's not bother about open apps anymore"!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .