27

Every time i write ... in a text editor like TextEdit or Coda, Lion has started replacing it with a single Ellipse character, which doesn't encode to HTML. This started after I upgraded to Lion and happens across multiple programs. This persists in the latest Big Sur betas.

Any idea how to stop it?

0

6 Answers 6

29

Go to System Preferences, select Language & Text, then the Text tab, and deselect the box for that option. enter image description here

Or you can disable the feature completely by deselecting the box at the top.

3
  • Thanks. I have done this and it works in all apps except Evernote. Evernote has no pref for this in the Preferences. Any idea of how to fix it? Thanks for entertaining this random aside. Nov 5, 2013 at 20:04
  • @Yar Sorry, I don't know. You could ask your own question specifically for Evernote and see if someone else does.
    – ughoavgfhw
    Nov 6, 2013 at 1:57
  • 2
    Certain apps seem to not respect the system "substitution" settings. In Adium, for instance, turn off ellipsis by opening a chat window, right-clicking in the textbox (where you type a message), then select Substitutions and de-select Smart Dashes. I could not find this setting in the actual Adium->Preferences dialog. A similar sequence might work for other apps with a composition field. See also this other answer.
    – hoc_age
    Nov 21, 2014 at 20:59
21

In Mavericks at least, this seems to be controlled by the "Use smart quotes and dashes" feature found in System Preferences → Keyboard → Text. Uncheck the box, and the behavior goes away, even in Evernote.

System Preferences → Keyboard → Text → Use smart quotes and dashes

3
  • 3
    I'm using TextEdit on 10.9.2, and I'm finding that I have to restart TextEdit for this change in System Preferences to take effect.
    – Ashley
    Mar 12, 2014 at 16:08
  • If you like smart quotes, but still don't want to replace the ellipsis, you need Luke's answer.
    – gpvos
    Mar 26, 2018 at 20:04
  • You may have to disable this in specific applications as well. (E.g., Mac Mail: Mail/Edit/Substitutions/Smart Dashes in Mac Mojave 10.14.6)
    – Dave X
    Jan 4, 2021 at 17:35
10

If "Smart Quotes" is active in Keyboard Settings but you don't want smart ellipses, Edit menu in most applications on OS X Yosemite, unchecking "Smart Dashes" found in Edit -> Substitutions -> Show Substitutions stops autocorrect of three periods to ellipsis.enter image description here

3
  • Resolved within Textedit or system wide?
    – Andreas
    Feb 14, 2015 at 20:58
  • See hoc_age's comment in the "hooked" answer - to get to this menu, you sometimes have to right-click on the input fields of the program that is suffering this issue. That is, the "Substitutions" menu item isn't in the Menu Bar, and only can be "found" by right-clicking on input fields. Bah.
    – fnl
    Mar 3, 2017 at 17:00
  • This works for me in Apple Mail (El Capitan).
    – gpvos
    Mar 26, 2018 at 20:03
9

On older OS X, you could see and disable this autocorrection, but now the interface is similar but you have to add this entry to manage it.

2020 screenshot of how ellipsis text replacement would appear in macOS

Make three periods generate three periods. Also look for app settings like smart quotes and dashes. Those can really be bad when writing code.

The official term for this is “Create text replacements” and you have to add the ones you prefer like I have shown...

9
  • Interesting that replacement does not even appear in KeyNote's preferences, but turning off "use smart quotes and dashes" does stop KeyNote from doing the replacement. I'll go ahead now and look for a system-wide Keyboard preference pane to see what's there (I have 10.15.6)
    – uhoh
    Sep 13, 2020 at 13:53
  • I don't see a ... there either, in fact no suggested replacements at all are explicitly listed at all, except "omw" i.stack.imgur.com/vf2qq.png but presumably turning off "use smart quotes and dashes" should do the same thing here.
    – uhoh
    Sep 13, 2020 at 13:56
  • You have to add it by clicking the plus in the bottom left. This is your place to override the system defaults. @uhoh I’ve edited in the applicable help article. It’s hard to search Apple when you don’t know the term to search. (And I didn’t know the term until you asked me...)
    – bmike
    Sep 13, 2020 at 14:03
  • 2
    Totally, I have tested this. Yes you “replace” the text with the exact same text. I’ll bold what I mentioned above override the system defaults
    – bmike
    Sep 13, 2020 at 14:18
  • 2
    Interestingly [or not, depending on your perspective;) because I never have 'smart quotes' set yet use an ellipsis frequently, I had to actually add it to text replacements.
    – Tetsujin
    Sep 13, 2020 at 16:48
3

It is a system-wide feature for text input, I guess it comes for free in Cocoa, maybe someone knows better.

To disable it right click in a text box (or open the Edit menu) and go to Substitutions and disable Smart Dashes (the dashes features also transforms -- to an en dash —.) You can also enable the Substitutions window from there if you need to toggle settings on a frequent basis.

The setting seems to be on a per document (or text box?) basis

Screen shot of context menu in TextEdit

3
  • Thanks! To double check, this works for Keynote, and it's on a per-document basis?
    – uhoh
    Sep 13, 2020 at 23:06
  • 2
    It works in Keynote but interestingly it’s an app-wide setting. In TextEdit it is per document. I’m not 100% sure about the scope of the setting (document, app, system) to be honest.
    – dlrlc
    Sep 13, 2020 at 23:14
  • okay thanks, one more piece of the puzzle... :-)
    – uhoh
    Sep 13, 2020 at 23:15
0

Press CmdZ immediately after a text substitution to undo it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .