2

I see no keyboard & character indicator on the menubar panel, and trying to enable "Show Keyboard & Character Viewers in menu bar" in System Preferences > Keyboard > Keyboard tab, that has no effect and, after closing and re-opening that settings window, Show Keyboard & Character Viewers in menu bar is still NOT ticked.

enter image description here

I use more than one keyboard layout and I need to permanently see the active one on the panel, and switch between them from there (at the present I can only switch from shortcut), like in this image I found on the internet:

enter image description here

  • 1
    I think that having more than one keyboard on your list in system prefs/keyboard/input sources should normally automatically put the "flag" menu in your menu bar, but I guess something must be amiss on your system. – Tom Gewecke Jan 31 '17 at 16:52
0

I think you are looking for this option:

enter image description here

  • I will look up the "Input sources" option as soon as I can. As for the rest more aggressive approach, looking at the link you posted - I am not sure I will try that, it seems recommended for more severe problems (before you bring it into the Apple Store) and also some comments there report chilling after effects. I will consider it though. I appreciate your assistance. – user61618 Jan 31 '17 at 12:17
  • I have mentioned the character viewer only in response to your comment that two buttons can be shown one in place of the other, I am mainly interested in displaying and switching keyboard layouts on the panel: from the button seen the image you posted, except I use more than one layout, as indicated in update to my question. – user61618 Jan 31 '17 at 12:51
  • I am almost sure that is the answer!! I cannot test on the spot but I will in a day or so. – user61618 Jan 31 '17 at 12:53
  • 1
    @cipricus if the answer resolves the problem, please remember to select the answer (and we can remove the comments as well) – Mr. Kennedy Jan 31 '17 at 12:56
  • 1
    as simple as that. i'll look into the 'not remembered' part too – user61618 Feb 1 '17 at 21:21

You must log in to answer this question.