1

I cannot see the files or folders on this external hard drive and I am unable to eject the drive. I must not lose this footage.

The drive is a brand new WD My Passport 25E1 Media 2TB External Hard Drive. I'm using it to store large amounts of video footage. It's only a few days old. I've had no problem transferring and opening files on the hard drive until now.

When I first purchased the drive I formatted it for MacOS using Disk Utility. It is currently a Mac OS Extended (Journaled) partition. It has never been plugged in to any other Mac or PC.

Current Problem

The hard drive is plugged in to my iMac.

  1. When I view it in Finder non of the hundreds of gigs of footage display. No files, no folders.

  2. I cannot eject the drive. If I attempt to eject the drive I get this message:

The disk "My Passport" wasn't ejected because one or more programs may be using it. I have not tried to Force Eject.

There is valuable footage on this drive I cannot lose. If I view the drive in Disk Utility it shows 318.15 GBs used and 1.68 TB free. This indicates the files are on the drive but not visible.

Steps I've Done So Far

  • Attempted to Eject the Drive
  • Confirmed Storage is Used in Disk Utility
  • Closed All Open Applications & Attempted to Eject the Drive
  • Logged Out of my MacOS User Account & Attempted to Eject the Drive
  • Opened WD Drive Utilities and Clicked "Run Drive Status Check" and "Run Quick Drive Test" with No Effect, Results, or Message. It doesn't do anything.

Right now I'm seeking guidance because this footage is essential and cannot be lost.

  • How do I confirm the files are still on the drive?
  • Why does the drive not display the files or folders it should?
  • Why can I not eject the drive?
  • Should I attempt a "Force Eject", and if I do, do I risk losing the files on the drive?
  • How do I identify what programs are running that are preventing the drive from ejecting?
  • How can I eject the drive?

Help in this matter is immensely appreciated.

1

Restart your Mac

At the risk of stating the obvious (as you didn't say you've tried this), have you fully shutdown your Mac and then rebooted to see if the drive appears and functions okay then?

Use a different port

Shutdown your Mac and try connecting the drive to another port. What happens?

Safe Mode

If restarting your Mac and trying a different port makes no difference, can you restart your Mac in Safe Mode and let us know how that goes?

Follow these steps boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. could you boot your Mac okay, is the issue still present, etc)
  6. To exit Safe Mode just restart your Mac as normal

Once you've booted into Safe Mode, let me know how you went and we'll go from there.

BACKUP

Finally, you really should have a backup of your data. You've made it pretty clear you have valuable footage on this drive you can't risk losing, so you really should have a second drive for backup purposes.

  • Thank you for your response. I have not tried these methods yet - I thought it better to try to identify the problem first to avoid risking the loss of the contents of the drive. – dope ideas Jan 31 '17 at 0:24
  • The data should still be on the drive. Regardless, doing a proper shutdown/restart will not damage the drive. That could only happen if the Mac suddenly lost power (e.g. Blackout) or if you just unplugged the drive (especially while it was being used) without properly ejecting it. But a proper shutdown/restart should unmount the drive without interrupting any processes. – Monomeeth Jan 31 '17 at 0:45
  • I restarted the iMac and the files are now visible in the drive and I can eject it. Perhaps I overreacted. Any idea why caused this problem, particularly why the files didn't display? Does it sound like I have a problem here or should I continue using the drive as intended? – dope ideas Jan 31 '17 at 5:27
  • What you experienced is not all that uncommon, but it's not something I expect to happen regularly. It is probably worth testing with Disk Utility - if all is good, continue using the drive. If it happens again, make a note of what the Mac was doing prior. And, if it happens again, make another note and see if you can establish some sort of trigger/pattern. Finally, you really should have a backup of your data. You've made it pretty clear you have valuable footage on this drive you can't risk losing, so you really should have a second drive for backup purposes. – Monomeeth Jan 31 '17 at 5:37
  • Thank you for your help. I'll look into getting a second drive. – dope ideas Feb 2 '17 at 22:46
-1

The SAME exact thing happened to me. Including storing a lot of video files on my drive and it being vital that I didn't lose any of them. I tried shutting down my MacBook and when I restarted it, the files were showing again in my WD EastStore 10 TB drive. THANK GOD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .