1

Yesterday I've installed bootcamp, Windows 10 Pro, on my new tb/MBP (late 2016). Everything worked fine until I've installed Visual Studio 2015 (Update 3) with all of its components (50GB~).

After I've rebooted the computer, it took ~10 minutes to load Windows (waiting at the dark screen with Windows logo and dots loading animation). Then - the keyboard and trackpad do not respond (even the keyboard light is turned off). The Touch Bar sometimes works and sometimes not.

I've rebooted to macOS and everything works fine.

I've read many threads and saw that it may be related to Hyper-V, which Visual Studio uses for Mobile Developement.

So, how can I disable Hyper-V so I can get back my MBP to normal? I don't want to re-install Windows, and I can't work without Visual Studio...

  • any success reagarding this ? – Abhi Jan 31 '17 at 11:51
  • I also have faced this issue I have enabled Hyper-V on my Windows installed on "Macbook Pro with TouchBar" – Abhi Jan 31 '17 at 11:52
  • Unfortunately not. Since I just received the computer and don't had anything on the Windows installation - I've re-formatted the Windows partition, installed Windows 10 again and then installed Visual Studio 2015 Update 3 again, only this time without anything related to emulation. The Windows partition works fine. This is not a comment worthy to be an answer, though. I'll glad to hear any suggestion that really solves the Hyper-V issue. – Gindi Bar Yahav Feb 3 '17 at 16:18
1

I've got Hyper-V working reliably under Windows 10 installed via Bootcamp on a 2016 MBP without TouchBar. The steps are relatively advanced, but were easy to follow and most people on this thread should be comfortable. You install and EFI boot manager called rEFInd (it's the "modern" successor to a tool I used to use on my old MacBook Air called rEFIt). By tinkering with rEFInd's configuration you can get it to EFI-boot Windows with the hypervisor enabled.

Follow the instructions here, CAREFULLY: http://nuts4.net/post/hack-force-vt-x-to-be-always-on-when-booting-to-windows-on-your-macbook

I also followed the steps in this article about enabling "legacy safe mode" for Windows 10 (allowing me to press the F8 key during boot if anything goes wrong): https://medium.com/@naokisatoname/newer-mac-windows-10-on-boot-camp-hyper-v-enabled-infinite-spinning-circle-5631b36f6d1

The net result is a clean install of W10 via Bootcamp, with working Hyper-V. I need to use rEFInd as my boot manager to EFI-boot Windows, but that's totally fine in my book.

I hope this helps people. I intend to cross post this solution on the other linked threads to get the word out there.

Regards, Mark

  • Could you edit your answer to summarise the steps? It means if the site goes down, or users here have odd firewall issues, the answer's all here. – John N Apr 4 '17 at 17:27
  • For the nuts4.net article, the steps are fully documented on another answer: apple.stackexchange.com/questions/281599/… – Joe the Coder Jul 15 at 19:31
0

I have the same issue and just found this post from Apple: https://support.apple.com/en-us/HT207469

  • Thanks. Looks like Apple didn't suggest anything useful - "if VS restarted your computer - you can reinstall the OS", really Apple?! Oh well, I've reinstalled the OS, installed VS again (and this time w/o any emulator) and everything works fine. It's just pity and annoying since I've bought the computer for development... – Gindi Bar Yahav Feb 27 '17 at 9:59
  • I am sure Hyper-V is not working only on the new Macs. I had a MacBook Pro (late 2013) with Hyper-V enabled, and I was able to run the HoloLens emulator without any problem. However, my new MacBook Pro (late 2016) doesn't work with Hyper-V. The post from Apple is quite recent, and it only mentions that no support for Hyper-V in Boot Camp in general. I guess Apple is not going to fix this. – Angus Lau Mar 2 '17 at 21:19
  • FYI, I was able to manually turn o Hyper-V on my MacBook Pro 15" 2016 with the touchbar. I simply enabled that feature and rebooted. Even turned on a Hyper-V VM that booted up. – DeepSpace101 Jul 28 '17 at 18:02
-1

Easy for disable the hiper-v: http://www.poweronplatforms.com/enable-disable-hyper-v-windows-10-8/ ...

  • Sorry but this link cannot solve the issue. Visual Studio auto activates Hyper-V so you have to re-configure it to disable it. The problem, like I've stated in the question, is that you can't use either the trackpad, keyboard or even external mouse/keyboard - so I can't re-configure it or do anything with the computer. In safe mode you can use the input modules, but you can't turn off Hyper-V. – Gindi Bar Yahav Feb 3 '17 at 16:20
  • Why cannot you? Just uncheck hyper-v module in Windows features. – Andre Luiz Feb 26 '17 at 22:10
  • I couldn't use uncheck hyper-v since, as I've explained, VS restarted the computer and then I couldn't use either the mouse and keyboard (even not external, wired keyboard and mouse). When booting into safe mode, the option was not checked (I read in some forums that you can't disable hyper-v from safe mode) - so there's nothing I could do :(. – Gindi Bar Yahav Feb 27 '17 at 9:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .