2

Every time I start Terminal, it starts minimized in the Dock. As I saw from this question, the problem is in my profile (under preferences) but I can't find any option to change this behaviour.

How can I solve the problem in my current profile?

Update

The proble is not specific to my profile - it occurs with all profiles I try using.

2

I'm using macOS 10.12.3 and Terminal.app Version 2.7.1 (388) and I don't see the "Hide after opening" checkbox option mentioned in the answer to the question you linked either.

From the Terminal.app >> Preferences::Profiles pane, look below the list of profiles. In the gear icon menu you can export your current profile in the gear settings menu options. Open the exported profile in a text editor and you might be able to find the setting which is causing this behavior.

mini settings menu

You could also try "restore default profiles" or simply rebuilding your profile from one that does not minimize at launch.

------------------UPDATE

If "Restore Default Options" doesn't work AND you are having this problem with all the profiles you try, it might be helpful to post your exported profile settings in your question.

Also, do you know which shell you are launching into?

To find out, enter this into your Terminal command line:

echo $SHELL

I am using the "Default login shell" and echo $SHELL reports /bin/bash

Are you using the "Default login shell"? You can find this setting in the Terminal.app >> Preferences::General pane:

Default login shell

Please post your OS and Terminal.app versions in the original question.

Also, after changing your profile, have you tried logging out, restarting and logging back in then verifying that the profile change is still in effect?

  • Thank you very much for your reply. I try to make new profile and I found that the problem is not in specific profile... Did you have any other solution in your mind? – yannisalexiou Jan 29 '17 at 0:43
  • @gioalexiou did you try the restore default option? – Mr. Kennedy Jan 29 '17 at 1:49
  • Thank you for your reply Restore default Ptofiles doesn't work. Unfurtunatelly I ca't re-install the Homebrew. I will continue search for solution, if you have anything more, please tell me! – yannisalexiou Jan 29 '17 at 10:23
  • @gioalexiou please see the updated answer. Hope this helps. If you are not using Homebrew (or X11) don't worry about them. Please export your profile settings and post them in your question. – Mr. Kennedy Jan 29 '17 at 15:19
2

It appears that a plug-in called "afloat" was causing this issue for me. You can blacklist Terminal from its settings and the issue will disappear. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .