1

I recently removed the Ubuntu disk partition from my macbook, now my osx or hdd is not recognizable and I am forced to perform the internet recovery mode to no avail.

Update: I swapped out my original hard drive with a SSD that I recently bought. My MacBook is up and running using the new SSD, however the original HDD when plugged in via USB appears in Disk Utility, but I am not able to use it.

enter image description here Upon clicking 'First Aid' for either ASMT 2115 Media or the other two "--" below it I received the error message "First Aid process has failed. If possible back up the data on this volume. Click Done to continue.

enter image description here

This entire problem happened when I tried to erase my Ubuntu partition (which I believe is the 2nd "--" under ASMT 2115 Media. Upon doing so, this is when this entire problem started.

Although I have a clean Sierra on my SSD, I would still want to be able to access this hard drive to see if I can salvage my photos, documents and programs already located on it.

Output of diskutil list:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.1 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Untitled                1.0 TB     disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            Untitled               +1.0 TB     disk1
                                 Logical Volume on disk0s2
                                 8CAA5C80-BB12-4432-9950-5DF80AA23AA8
                                 Unencrypted

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS                         302.6 GB   disk2s2
   3:                  Apple_HFS                         17.1 GB    disk2s3

Here is the result of diskutil info /dev/disk2s2 which was my original HDD

Device Identifier:        disk2s2
Device Node:              /dev/disk2s2
Whole:                    No
Part of Whole:            disk2

Volume Name:              
Mounted:                  No

Partition Type:           Apple_HFS
File System Personality:  HFS+
Type (Bundle):            hfs
Name (User Visible):      Mac OS Extended
Journal:                  Unknown (not mounted)
Owners:                   Disabled

OS Can Be Installed:      No
Media Type:               Generic
Protocol:                 USB
SMART Status:             Not Supported
Disk / Partition UUID:    000059E3-08FD-0000-6F45-0000C7470000

Disk Size:                302.6 GB (302643589120 Bytes) (exactly 591100760 512-Byte-Units)
Device Block Size:        512 Bytes

Volume Total Space:       0 B (0 Bytes) (exactly 0 512-Byte-Units)
Volume Available Space:   0 B (0 Bytes) (exactly 0 512-Byte-Units)

Read-Only Media:          No
Read-Only Volume:         Not applicable (not mounted)

Device Location:          External
Removable Media:          Fixed
  • How do you know that your "osx or hdd is not recognizable"? Have you tried to take a look at your HDD with Disk Utility when booting from the recovery partition (CMD+R)? – oa- Jan 28 '17 at 20:59
  • @oa- I believe it stated that earlier on when I was in disk utility. However, now the disk utility (when I click 'Verify Disk') states "Error: This disk needs to be repaired. Click Repair Disk" but when I do so, it says "Error: Disk Utility can't repair this disk...disk, and restore your backed-up files. " – Jeff Jan 28 '17 at 21:12
  • i.imgur.com/5OvVcFJ.jpg @oa- – Jeff Jan 28 '17 at 21:17
  • What's the SMART status of the HDD? Have you tried repairing full disk and full disk permissions? (Select top disk instead of disk0s2). If I had to guess, I'd say you have a bad partition map or efi partition – NoahL Jan 28 '17 at 21:38
  • Thank you @NoahL. I updated my question above, and I have tried to repairing the full disk to no avail. I believe you are correct regarding it either being a bad partition map or efi partition. I am unfortunately not the greatest with figuring this things out. Do you know if there is anything to get this drive working again? – Jeff Jan 29 '17 at 0:33
1

Googling issues with ASMT 2115 on macOS brought me here. I had an issue, similar to yours, when testing this external hdd enclosure.

Somehow by formatting SSD in Yosemite from Parallels (which was previously formatted on Sierra), I managed to get HDD into state which nor Sierra nor Yosemite could read/mount/format anymore on macOS. I could use eg. Ubuntu to format the disk, but that was not the point. I wanted to understand what is going on and why macOS started hating my disk.

I was not able to partition the disk or erase it from Disk Utility. The useless ultra generic error messages was not helpful at all, so I tried to format it from terminal with diskutil eraseDisk HFS+ OSX GPT /dev/disk3. There I was able to partially format the disk but finalisation broke with more errors. I was suspicious about electronics in this enclosure and macOS driver for it because I had several of them, and several SSD HDDs all showing same issue. All that lead me to investigate MBR/GPT of the disk in question.

What was strange to me was that fdisk saw unknown partition ID and gpt did not work at all.

Disk: /dev/disk3    geometry: 14593/255/63 [234441648 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -  234441647] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused       

And gpt did not work at all:

sudo gpt -r show /dev/disk3
gpt show: error: bogus map
gpt show: unable to open device '/dev/disk3': Undefined error: 0

Then I found about Hybrid MBR/Protective MBR/GPT issues people had, mostly due to BootCamp which was responsible for creating the Hybrid MBR conditions that was causing many problems to dual boot users (lost system partitions etc.). I was certain I created condition like that by my self (by using different non compatible OSX versions tough).

The solution in this case was to clear the hybrid MBR data, or even better to clear all GPT/MBR data on the disk (if you do not need the data), and start over.

I was not able to use Apple utilities successfully, but GPT fdisk (gdisk) worked great for me. SIP fill forbid gdisk from working on system disk (unless it's disabled), but it works great with external HDDs. gdisk revealed that my MBR and GPT were very different.

sudo gdisk /dev/disk3
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: present

Found valid MBR and GPT. Which do you want to use?
 1 - MBR
 2 - GPT
 3 - Create blank GPT

It's worth noting that:

  • Option 1 reads MBR partition table (as seen by fdisk) and converts them to GPT.
  • Option 2 uses existing GPT (as seen by gdisk) and deletes the MBR partition table (becoming protective MBR)
  • Option 3 will start fresh with a new empty GPT.

If you want to save data on your HDD, do not do this. You have to repair it from gdisk. My fix was using option 3, then zaping (deleting all partition information) whole disk and recreating blank GPT:

x
z
Yes
y

After that I was again able to initialise/format the disk in Disk Utility again (and in terminal).

More info about GPT can be found here and here on gdisk homepage.

The fastest way to get gdisk is by brewing from cask with: brew cask install gdisk

Hope this helps someone.

IMHO - it is not unlikely that disks will end up this way if they are eg. used between OS'es. macOS should really have support to handle them without breaking a sweat, but sadly - it does not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .