1

I have a very strange problem, and it started since I got my LG 5K Ultrafine screen and started using an external keyboard and mouse.

I usually notice it in Blender, so it might be related to that.

I use the middle mouse button to rotate the view in Blender, and suddenly it acts as if I'm holding down the mouse button, even if I'm not, and when I move the mouse the view rotates.

Now if I switch to a browser, like Chrome, the middle mouse button doesn't work. I can't close tabs for example, which usually works.

Using the track pad, I can triple finger click, and it works as it should.

I have a couple of mouse controlling apps, to make it work like I'm used to from PC, and it might be causing these issues.

  • Smart scroll (to controll scroll speed in different apps)
  • USB overdrive (to disable the horrible acceleration)
  • Logitech control center (which only works when a Logitech mouse is in)

I just tried switching to a Logitech mouse, and it has the same issues as the other mouse, which is a Corsair (which doesn't have Mac drivers, but it usually just works)

Suddenly it just starts working again, and also a reboot helps, but it's so annoying since it happens like once every 30 minutes or so.

So it's a weird problem, and I'd be happy to know if anyone has had anything similar?

  • Have you disabled the three mouse apps one by one to see which is the culprit? Have these apps been updated recently, or do they need updates? How are you connecting your LG screen? Lastly, which model of Mac are you using, and what version of macOS is running? – IconDaemon Jan 27 '17 at 22:00
  • Thanks, It seems as if toggling USB Overdrive on and off when it happens, it resolves the problem. It didn't work like that the first time, but now at least I have a solution to this. – Niclas Jan 28 '17 at 0:05
  • I added the 'solution' in as an answer. – IconDaemon Jan 28 '17 at 0:09
1

USB Overdrive was the culprit, and I found that it happened when I held the scroll wheel clicked and scrolled at the same time. By disabling/enabling USB Overdrive, it started to work again.

However, when I disable the setting "Wheel button: Middle button", this stopped happening, and the middle mouse button works as it should.

  • Disabling alone didn't help for me. Did sudo kextunload -b com.usboverdrive.driver.hid ; sleep 10; sudo kextload -b com.usboverdrive.driver.hid which recovered the USB devices shortly afterwards and made the middle button work again. – AndiDog Apr 16 at 6:22
0

You should experiment by disabling one or more of the three USB apps to see if they cause the problem. I would guess one (or more) of them cause this glitch.

  • Thanks, but the real solution was to change a setting in USB overdrive, I posted that as an answer. Thanks for pointing me right though! – Niclas Jan 29 '17 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .