Every time I force quit an application from Activity Monitor, I get a pop-up saying "You have forced to quit. Click Report to see from detailed information and sent a report to Apple.". It gives me the option to Ignore or Report.

Is there a way to stop getting this notification altogether? In System Preferences > Security & Privacy > Privacy > Diagnostics & Usage I already have everything unchecked.

I found this on the web and also tried writing this on the terminal

defaults write com.apple.CrashReporter DialogType none

But this didn't help either.


1 Answer 1


Using defaults write com.apple.CrashReporter DialogType none really should disable it, just like using defaults write com.apple.CrashReporter DialogType crashreport should switch it back on.

However, if it's not working for you, you can try the following two commands:

launchctl unload -w /System/Library/LaunchAgents/com.apple.ReportCrash.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.ReportCrash.Root.plist

To undo the above change, you would use the same two commands, but replace unload with load in each.

Use a notification instead

Removing the Crash Reporter may be overkill for some users, so another option is to change this to a notification instead. To do this, use:

defaults write com.apple.CrashReporter UseUNC 1

The advantage of this is you still get notified if an app has crashed, but you don't have to respond in any way (nothing to click on). To undo this change you would use the same entry but replace the 1 with a 0.

  • 1
    I tried your suggestion with the 2 launchctl commands, but it didn't fix my issue. I have added a screenshot (to the question) of the error I get.
    – user10
    Jan 29, 2017 at 0:13
  • 1
    BTW, changing it to a notification gives the following error: $ defaults write com.apple.CrashReporter DialogType UseUNC 1 2017-01-28 16:14:00.825 defaults[51957:42406743] Unexpected argument 1; leaving defaults unchanged.
    – user10
    Jan 29, 2017 at 0:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .