3

I just installed a new ssd (samsung 250gb - 850 evo) and new RAM (8gb).

now for the problem... I installed snow leopard from the disc that came with the MAC, and then updated the software as much as i could (By searching for updates). Now, I wanted the get the most recent OS, sierra, but it turns out you have to upgrade to El capitan first... Anyway, i download the EL Capitan in the Appstore and procede. The installation seems fine, but in the end it said "Installation failed" and im left with the choice to reboot and try again. same result over and over.

Am i missing something? I formated the new ssd to OS x journaled and choose the GUID partition table.

[EDIT] Here are links to some screenshots:

http://i67.tinypic.com/x2tonq.jpg enter image description here

3

The installation fails due to a crash caused by the SystemMigrationUtils process while it tries to talk to the battery of your MacBook Pro:

Jan 27 11:29:21 […] Thread 8 Crashed:: Dispatch queue: com.apple.root.default-qos
Jan 27 11:29:21 […] […] 0x000000011b3adff7 logBatteryState + 963

The fact that this fails is indicative of an issue with the battery of your MacBook Pro.

To fix this, first be sure that you are not only connected to the mains but also have a working battery actually attached to the logic board of your MacBook Pro. (Source: Apple Communities)

Second, reset your NVRAM by turning off your Mac, holding PR and turning your Mac on again. Make sure to hold the buttons until you hear the startup chime for the second time.

Shut down your Mac one more time, then reset its SMC by pressing Ctrl and the Power button at the same time. Your Mac needs to be connected to a power supply during that entire process. Keep an eye on the little light on the MagSafe plug while you hold down the for keys. Release the keys at the same time. The MagSafe light should change colors for a second or so; if it doesn’t, retry until it does. Now try installing El Capitan again. (Source: Reset SMC of a MacBook Air, MacBook Pro Retina, or MacBook Pro’s with an internal non-removable battery)

If the installer still crashes during logBatteryState, try resetting the system management controller by physically removing the battery from the logic board. To do this, you’ll need to remove the screws from the bottom case, lift the case just like you did back when you installed the SSD. Locate the battery, then remove the three screws to detach it from the logic board (two screws are in plain sight and the third screw is hidden under a warning label.)

Now lift the battery a bit, remove the connector from the logic board, press the Power button and hold it down for 10 seconds with the battery still disconnected. Now reattach the battery and retry the El Capitan installation one more time. (Source: this comment on ifixit.com)

If you have followed all the steps and the crash still occurs during logBatteryState, you might want to get another battery of the same model that is confirmed to work, then install it in order to figure out whether there is an issue with your battery; if not, it might be an issue with the PMC on your logic board.

  • 1
    Well that makes sense... I havent got a battery in the mac atm (It swelled up and im awaiting a new one) Did not know that was relevant :O – Kristoffer Jan 27 '17 at 22:42
  • 1
    Thanks alot for the great and well written answer btw! ill try when the new battery is installed. – Kristoffer Jan 27 '17 at 22:43
-1

I have managed to enter new OS by pushing Shift and thus booting into Safe mode. I've got asked several questions about my time zone, keyboard layout etc, and it ended with Login screen with newly created user. However, the next problem is that installer remained "sticky" somewhere. Every time I tried to boot in non-safe mode, installer was starting again. I have no idea where does it write, but I guessed that if I try to update system, that update will overrride installer in the boot options. Indeed, I've got different message after reboot: "Installing Software Update". And then after reboot I was finally in the new OS in normal mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .