2

I also have a partion with Ubuntu installed. Unfortunately, every time I have an error while working on the Ubuntu partion (I believe it's ext3), I get a Kernel Panic and I have to restart. I believe this is related to fseventsd, since it my try to log the errors on the root of the Ubuntu partition.

How can I stop fseventsd logging events on that Ubuntu volume?

Thank you!

  • 1
    There's been some confusion about this question and how it relates to Mac OS X. As I understand it, the Mac process fseventsd is messing up your Ubuntu partition and causing kernel panics, and your question is how to tell Mac OS X to stop fseventsd logging for a particular volume. Is that correct? If so, this question is on topic for Ask Different. – Nathan Greenstein Oct 9 '11 at 3:55
  • Yes Nathan, I need to stop that process from logging errors for my Ubuntu partition. I believe it might be a conflict of permissions that causes this kernel panics whenever I am working in the terminal on the Ubuntu partition, and I get an error message (stderr). – Mihai Neacsu Oct 10 '11 at 8:24
4

Preventing file system event storage

Whilst you should not stop the daemon, you can disable logging on a per-volume basis.

In the Mac Developer Library

File System Events Programming Guide: File System Event Security: Preventing File System Event Storage advises:

… To disable logging on a per-volume basis (for creating a backup volume, for example), you must do the following:

  • Create a .fseventsd directory at the top level of the volume.
  • Create an empty no_log file in that directory.

So if your volume is mounted at /Volumes/MyDisk, you would create an empty file called /Volumes/MyDisk/.fseventsd/no_log.


Kernel panics

Please consider creating a separate question.

1

OS X does not have a built-in ext3 driver so it's not possible to even access the Ubuntu partition from OS X.

There is a lot of information missing here making it impossible to correctly assess what is causing your kernel panic.

Are you even using Apple hardware?

  • Yes, I am using Apple hardware. In order to access ext4 (Ubuntu partition) I'm using 3rd party driver from Paragon (Paragon ExtFS). From what I understand, the fseventsd process writes error logs on the root of the partition that you are working on. So, let's say I am working in terminal on the ubuntu partition, once receive and error message there, I get my kernel panic. I need to know how can I stop this process to stop logging error messages for my Ubuntu partition. – Mihai Neacsu Oct 10 '11 at 8:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .