I'd like to change the time format from 12 to 24 hours in the log queries.

The logs themselves are already in 24-hour, but the queries show in 12-hour format.

I checked asl.conf's man page but I couldn't find an option, nor did perusing the actual file at /private/etc/asl.conf.

I also checked the default All Messages query file and a custom one, to no avail, at /Applications/Utilities/Console.app/Contents/Resources/ASLQueries/All Messages.aslquery.

Make sure you select View>Show Milliseconds to reproduce it, which seems to override the setting Medium in System Preferences>Language & Text>Region>Times>Customize….

I use Console.app v10.8 on Mountain Lion.

  • Have you an example query - all of my entries are in 24hr format. ALso what are your date and time settings in Preferences
    – mmmmmm
    Jan 26, 2017 at 9:51
  • If you can live with working on the command line, have a log at man syslog. You can conveniently search for messages, and format them how you like. Using e.g. syslog -F '$((Time)(sec)) $Host $(Sender)[$(PID)] <$((Level)(str))>: $Message' will print the time in seconds (epoch).
    – Asmus
    Jan 26, 2017 at 10:02
  • 1
    What's your 24hour clock setting in system preferences -> language & region?
    – Asmus
    Jan 26, 2017 at 11:01
  • ntp server is irrelevant here
    – mmmmmm
    Jan 26, 2017 at 11:04
  • @Mark, check View>Show Milliseconds to reproduce it.
    – 1.61803
    Jan 27, 2017 at 13:04

1 Answer 1


For El Capitan - macOS 10.11.6

Go to System Preferences->Language and Region and choose the Time Format.

Changing it to non 24hr seemed to give a quick response in Console but changing back seemed to need a restart of Console.app

  • As I said above, View>Show Milliseconds seems to override those settings.
    – 1.61803
    Jan 27, 2017 at 13:39
  • Not for me ..... and you have not mentioned what state the toggle I mentioned is you have mentioned something else
    – mmmmmm
    Jan 27, 2017 at 14:34
  • I use Console.app v10.8. And in System Preferences the pane is Language & Text, there's no Time Format toggle.
    – 1.61803
    Jan 27, 2017 at 15:15
  • That needs to go in the question I am on 10.11.6
    – mmmmmm
    Jan 27, 2017 at 15:26
  • Could you post the key that's written to whatever the plist for System Preferences in El Capitan is called and saved? In 10.8 is ~/Library/Preferences/com.apple.systempreferences.plist.
    – 1.61803
    Jan 27, 2017 at 18:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .