1

OS X El Capitan 10.11.6.

Viewing webpages with syriac characters, e. g. Syriac Wikipedia, I get only empty boxes (the default character). I tried all three popular browsers (Chrome, FireFox, Safari), terminal, Libre Office, TextWrangler.

This webpage syriaca.org has a teststring, which renders correctly, but specifies the font in CSS.

If I write a small HTML file with CSS specifying an installed Syriac font, it displays correctly:

<html>
<head>
<meta charset="utf-8">
<style>
.syr {
    font-family: "SertoUrhoy", "Serto Urhoy", Verdana, Arial, Helvetica, sans-serif;
    /* font-size: large; */
    font-size: 1.25em;
    line-height: 1em;
}
</style>
</head>
<body>
<p class="syr" dir="rtl">
ܫܠܡܐ
</p>
</body>

Also on syriaca.org a problem on Mac is mentioned:

Even with Meltho or other fonts installed there is also a known conflict with Apple's default rendering of the ܘ (waw) character when a conflicting Arabic font is installed.

What can I do to solve this Problem? CSS is only a solution for HTML written by myself.

  • I have no problem displaying the wikipedia page with 10.11.6 and Safari. Firefox fails, Chrome displays half script/half boxes. – Tom Gewecke Jan 25 '17 at 13:17
  • In Safari 10.0.3 (& Beth Mardutho's font package installed to the user's fonts folder) and a more or less vanilla 10.11.6 it works for me without any further mods. In Chrome only some (most) words show properly. Firefox fails completely. – klanomath Jan 25 '17 at 13:17
  • In my case I need many fonts for exotic writing systems. Maybe some of the other fonts cause a problem? – Helmut Wollmersdorfer Jan 25 '17 at 14:13
  • I remember a couple years ago you had to deactivate Apple's Damascus font to avoid problems, but don't know if that is still necessary... – Tom Gewecke Jan 25 '17 at 15:14
1

Not a perfect solution but now I found a way to have the characters rendered in all programs.

From the comments to the original question I assume that an installed font is poisoned by wrong glyphs or defect in some other way. For a quick diagnosis I installed Ultra Character Map. It didn't help much to locate the defect font, but used the built in Google Noto Font to render characters.

Before diving deep into writing Perl scripts for font analysis, I installed all Google Noto Fonts into user fonts and everything works now, also Dhivehi.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .