We have a network with 40 machines and all of our machines are showing in Finder except for our Windows Server 2011 which is not showing under network computers in Finder.

I can connect using Go -> Connection to server -> smb://ipaddress but I'm wondering if there is a way to get it to also show as a machine in the list.


Have you added each Mac to the Windows workgroup?

  1. System Preferences > Network
  2. Select the relevant network interface from the sidebar (Ethernet, Wifi etc)
  3. Click 'Advanced'
  4. Click 'WINS'
  5. Enter the name of the Windows workgroup in 'Workgroup:'
  6. Click the + button and enter the IP address of your Windows server in place of
  7. Click 'OK' and 'Apply'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .