3

So I'm in a rather strange situation. I have an SSD, and I am using a SATA to USB 3 adapter (basically an enclosure, as it is called) to connect it to my laptop. This worked fine with a mid-2012 MacBook Pro.

I tried to use this SSD with with a retina late 2012 MacBook Pro, only to find that it wasn't recognized at all by the MacBook. It didn't show up in the Finder, in Disk Utility, or even in the "System Information" USB section. It seemed as though it wasn't even connected. The USB ports on the MacBook are functional.

I tried formatting it with macOS Journaled, exFAT, and even NTFS, but to no avail. I decided to see if this would happen with other MacBooks. I connected it to another retina MacBook Pro, and it wasn't recognized. I connected it to a MacBook Air, and it was. When I formatted it to exFAT I connected it to a Windows computer, and it was recognized (and that's how I tried formatting it as an NTFS drive).

As some additional information, when I connect the SSD to the MacBook Pro, the enclosure light lights up, meaning that power definitely goes to it. However, it doesn't blink at all (which would suggest some operations were going on).

So from this, although I haven't tested an exhaustive list of computers, it seems as though the SSD won't work with newer, retina MacBooks. Is there any explanation for this? Is there any way in which I could make it work again? Is there a problem with my SSD, the adaptor, the USB 3.0 Micro-B 10 Pin to USB 3.0 Type A wire that I am using? Or is there a problem with newer MacBooks in general which don't allow such SSDs to be connected to the laptop with this adapter (which seems like the most likely of these)? Are there any drivers I need to install for it to work? (This doesn't sound likely, though).

Has anyone here had any luck with connecting an external SSD to their (retina) MacBook Pro?

Running diskutil list after connecting the external SSD, as was suggested by Allan in the comments, gives this output:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            120.5 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            Macintosh HD           +120.1 GB   disk1
                                 Logical Volume on disk0s2
                                 XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
                                 Unencrypted

This is the same output that I get when I don't have the SSD connected.

  • The question is...is it being "recognized" and not mounted or not recognized at all? When you connect your external SSD to MBP, go into Terminal and issue the command diskutil list and post the output. – Allan Jan 24 '17 at 16:54
  • @Allan I'm not sure if I should post the whole output due to sensitive information, but I edited the information into my post. Thank you for your comment. – user221524 Jan 24 '17 at 17:08
  • Just to confirm, you only get disk1 and disk2. If you issue the command system_profiler SPUSBDataType it will list all devices attached to the USB bus. Scroll through and see if you can find your device. If you pipe the output to pbcopy it will go to your clipboard so you can paste it into a text editor or something for easier viewing. Just append | pbcopy to the command above. – Allan Jan 24 '17 at 17:56
  • Yes, well, I get disk0 and disk1 only. The code block in my post is the whole output for the diskutil list command (except I changed the "serial" to XXXX....! I tried the system_profiler SPUSBDataType command, and got this output. My drive doesn't show up there (it's the same output as when the drive isn't connected). When I connect it to the older MacBook however, it does show up – here is what it looks like. – user221524 Jan 24 '17 at 21:38
  • What versions of macOS are you running and what's the brand of USB drive? – Allan Jan 24 '17 at 23:09
1

It seems like, since the SSD is not recognized at all, and:

  • The USB ports fully function
  • The SSD fully functions (with older Macs and Windows computers),

the only conclusion to come to is that the adapter uses drivers which are not present in newer MacBooks. Even if the old and new MacBooks are on the latest version of macOS (Sierra as of writing this), there is some connection between the adapter and the hardware you are trying it on.

Solution: use a different adapter (this solved my problem!)


Many thanks to Allan for his help resolving this issue. This answer has been posted with a different account by has been written by the same person who posted the above post (I lost access to that account somehow.) Likewise I can't choose this as the answer to the question, but if Allan sees this and writes his own answer, I will delete this one and vote him up. (I can't ping him as I have <50 rep)

  • Problems like this can sometimes be solved with firmware updates, assuming you can find out who made the chipset in your enclosure. – Michael Stern Jan 26 '17 at 19:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .