1

So around last month my dock decided to make my notification badges blue and very large. I have no clue why. I’ve tried resetting the preferences, restoring them from time machine, restoring Dock.app from Time Machine and nothing works. Whatever caused this, also broke LaunchPad because the instant I try to open it, it just crashes, the dock quits and restarts, and it never appears. Any ideas?

Retina 5K iMac (iMac15,1) macOS 10.12.1

  • Can you please specifiy the machine and the macOS version you're using? – oa- Jan 24 '17 at 14:23
  • 1
    @oa- just added the details – Alex Jan 24 '17 at 14:41
1

First off, I would install any macOS software updates from the App Store in case it's a weird, uncommon bug with that version. (Current version is 10.12.2)

If your issue is not resolved after this, I would highly recommend testing in a new user account to determine whether or not the issue is system-wide. You could also boot into Safe Mode to see if the issue persists there. This would narrow down the list of possible culprits immensely!

If the issue appears to be user-based not system-wide, and still occurs in Safe Mode, I would then recommend rebuilding the the Launchpad database if you haven't tried this already.

When an issue does not occur in Safe Mode and has not resolved itself after restarting out of Safe Mode (yes, it can happen - albeit not often), it usually points to an issue with a kernel extension, third-party font, or a startup/login item. So at least if this is the case, we'll know where to start looking.

To rebuild the Launchpad Databases:

Note: Having a backup of your system is highly recommended as some of the tasks you will be performing delete user library data; not to mention you will be working with a couple of Terminal commands which if typed incorrectly can cause issues with your system.

Click here for my reference

  1. Quit Launchpad, if it's open. You can do this by clicking anywhere in the Launchpad app, as long as you don't click on an app icon.
  2. Open a Finder window.
  3. You need to access your Library folder, which is hidden by the operating system. You can gain access to this folder by using the instructions in OS X Is Hiding Your Library Folder. Once you have the Library folder open and visible in the Finder, you can continue to the next step.
  4. In the Library folder, locate and open the Application Support folder.
  5. In the Application Support folder, locate and open the Dock folder.
  6. You'll find a number of files in the Dock folder, including one named desktoppicture.db, and one or more files starting with a dashed set of capital letters and numbers, and ending in .db. An example file name is FE0131A-54E1-2A8E-B0A0A77CFCA4.db. Grab all the files in the Dock folder with the dashed set of letters and numbers that end in .db and drag them to the trash.
  7. Launch Terminal, located in the /Applications/Utilities folder.
  8. In the Terminal window, enter the following: defaults write com.apple.dock ResetLaunchPad -bool true
  9. Press enter or return to issue the command.
  10. In the Terminal window, enter: killall Dock
  11. Press enter or return.
  12. You can now quit Terminal.

I would suggest restarting your Mac at this point and then testing the issue. Keep in mind that the first time you open Launchpad it has to rebuild the databases it needs so it may take a bit longer to launch.

  • So interestingly, different users do not fix the issue. Nor did a launchpad rebuild. In fact it still crashes. However, safe mode did fix it – Alex Jan 26 '17 at 22:46
  • @Alex Are you saying that the issue is resolved after booting back out of Safe Mode or only that it did not occur while you were in Safe Mode? – NYKg Jan 28 '17 at 5:11
  • it only did not occur while it was in safe mode. I actually managed to fix the issue. I think some permissions got screwed up on Dock.app, so I ran a permissions repair and it took care of it. It was a very strange problem – Alex Jan 28 '17 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .