4

I use an Android phone but many of my friends and family have iPhones. Starting a few months ago I discovered that several people sent me text messages that didn't go through. And after digging into the problem, I discovered that their messages appeared as blue on their phone, not green, indicating that iMessage didn't convert it to a standard text. Then I discovered that (at least for some of the people), their texts were being sent to my email, not my phone number. The weird thing is that I don't even think some of these people had my email.

I do have an iCloud account because I own a Mac, and somebody has indicated that can lead messages to your email address. But I'm not sure. How can I, once and for all, deregister my email (not my phone number, that's already been asked) from receiving iMessages and have my friends' Messages apps only suggest my phone number as a destination to text me at?

tl;dr: My email is registered as an iMessage destination, but I need to deregister it so my iPhone-using friends only send SMSs to my phone number.

Just to be clear: This post is not a duplicate of asking how to deregister your phone number from iMessage. I never had an iPhone when iMessage existed and when I try using the deregister iMessage page it just says my phone number is not registered with iMessage.

10
  • You'll need to turn off iMessage. Follow Apple's steps here: selfsolve.apple.com/deregister-imessage
    – owlswipe
    Jan 22, 2017 at 17:01
  • I already tried before and it said my phone isn't registered with iMessage. I just tried again to confirm the same behavior. I did own an iPhone, but I got it approximately 8 years ago (2nd generation ), long before iMessage existed. I switched to Android approximately 6 years ago. Again, long before iMessage
    – J-bob
    Jan 22, 2017 at 21:40
  • 1
    Ok then, try this: on your Mac, go to Messages -> Preferences (in the menubar) -> Accounts tab -> and turn off your email address for "you can be reached at".
    – owlswipe
    Jan 22, 2017 at 23:15
  • @owlswipe - thanks for the flag - please edit the post to clarify how this isn't a dupe. Then if you can answer / flag comments for cleanup - super bonus. Thanks all
    – bmike
    Jan 23, 2017 at 0:10
  • @bmike Edited the post, waiting for OP to respond a second time before posting answer.
    – owlswipe
    Jan 23, 2017 at 1:36

3 Answers 3

2
  • Open the messages app on your Mac.

  • Open preferences from the Messages menu at the top of the screen.

  • Select the Accounts tab of the preferences window.

  • Uncheck enable this account

In future iPhone users should not find that messaging you defaults to an iMessages and rather to a SMS message.

The following video demonstrates these steps:

https://youtu.be/C5ilqv8NruE

This is a particularly nasty ongoing bug which does not rely on ever having had a iPhone and is particularly difficult to detect because the sender thinks they have sent you a text message(s) and the (non-)receiver is none-the-wiser that they are missing any messages/ignoring someone.

2
  • This answer is basically what's already in the comments. It's good that you answered a question but it would be even better if you can find an unanswered question and add a unique answer to help the other use. - From Review.
    – fsb
    Sep 11, 2018 at 20:03
  • Yes, I did see that the answer is in the comments and everyone seemed to agree that it was right, then they all forgot to post the answer whilst waiting for each other to confirm (?) something. Better to use the actual answer section on stack exchange sites - otherwise the question looks unsolved! - upvoting and accepting answers are there to encourage this (hint, hint) Sep 13, 2018 at 9:21
0

Once you’ve deregistered your SMS in Apple’s system, there’s no way to stop people from contacting you via SMS or email.

It’s the same as if you wanted to stop spam / unwanted SMS messages - you can ask the person sending to block and you can contact your carrier to ask how you can control spoofed / spam messages. In the end, you are paying that carrier to let other people contact you and have to work with them to get assistance blocking or changing your number.

It’s also the same as if you have spam email. You can ask the sender to stop or you can work with your mail delivery service.

Note - unsubscribe and spam block rules are hard and ineffective when the sender doesn’t respond and just hits every possible number or address. In your case, if it’s friends or aquaintances, you’ll likely be able to ask nicely and fix that.

-1

I'm on a newer version of macOS (Big Sur) that doesn't have the "enable this account" option available to uncheck in iMessage. Here's how I got around this issue:

  • Apple menu > System Preferences > Apple ID > Name, Phone, Email
  • Add a new email to the "Reachable At" field. You can add a junk email address, or just add some . or + to your regular email address, iMessage will still consider it different. Follow the steps in the verification email to verify it.
  • Close System Preferences, and a prompt will pop up asking "Do you want to add [new email] to iMessage and FaceTime?" click "Yes".
  • Open the Messages app, then open preferences from the Messages menu at the top of the screen.
  • Click the iMessage tab at the top of the preferences menu.
  • The new email should be listed under "You can be reached for messages at". Check the new email, which will allow you to uncheck your Apple ID email.

Text messages from iMessage will no longer be sent to your Apple ID email!

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .