So I own a MacBook air Air 13 11" which worked fine for about 15 months after I purchased it on Adorama.

One day, I was using it and it froze. Command+Option+Esc would't work so I had to push power button to shut it down. When I turned it back on, it showed me the interrogation folder. Internet recovery didn't work and the computer couldn't even read/recognize the internal SSD. So I got the SSD replaced and the computer worked fine for a week. Then, same problem again.

Sometimes I turn the computer on and it works fine. Sometimes it gives me the interrogation folder. Today I froze 3 times already. Then I have to open it, take out the SSD, put it back on, turn on the computer. It works for a while and then it freezes again...

Ever happened to anyone? Any idea what could be going on?

  • Did you replace the SSD yourself or did an Apple Store do it? Have you checked to ensure that the cable connecting the SSD to the logic board is firmly attached and not faulty? Are you currently able to get to the Recovery Partition or Internet Recovery after the SSD replacement? After replacing the SSD did you restore a backup to it? What OS is it currently running? – NYKg Jan 22 '17 at 3:32
  • By *interrogation folder" I am assuming you mean "flashing folder with a question mark." If this is the case, it's telling you that it cannot find a bootable partition. Given that you have an SSD, I would first run Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected. – Allan Jan 22 '17 at 3:32
  • @NYKg I replaced it myself. Cable is properly connected. The computer is working right now. Sometimes it just freezes and if I try to turn it back on, I get the flashing folder with a question mark. If I try internet recover at that point, it won't read or recognize the SSD. I need to open the computer, remove the SSD and place it back. The I turn it on and it works... I've been doing this for days now. Right now I'm using Sierra (10.10.2) but before I was using El Capitan and I had the exact same problem. I also run Apple Hardware Test and it didn't detect any problems... – Felipe Blanco Jan 26 '17 at 20:13
  • @FelipeBlanco What you're describing sounds like either a faulty hard drive cable or a failing hard drive. Since a cable is much cheaper than a new SSD, I would maybe try replacing that first to see if that resolves your issue, seeing as how the AHT didn't find an issue with the SSD. – NYKg Jan 28 '17 at 5:09

Try the Fool Self-test tool on DriveDx (has trial), there is also in App Store

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .