5

There are indeed countless of these questions, some of them succesfully answered. I recently purchased an ACER R241Y.

I started using Sketch and noticed the fonts quality was noticeably worse when on the Acer.

System Information:

El Capitan 10.11.6 (15G1217)
MacBook Pro (Retina, 13-inch, Late 2013)

Here are the screenshots: external built-in

I tried the infamous patch: Force RGB mode in Mac OS X to fix the picture quality of an external monitor, the defaults write NSGlobalDomain AppleFontSmoothing -integer X setting.. I am using a DVI -> Thunderbolt(Mini DisplayPort) cable. (I tried HDMI<->HDMI as well).

  • What model Mac? What version of macOS? – Monomeeth Jan 22 '17 at 1:14
  • Your retina has a resolution of possibly 2880x1800 in a 15" screen. Your new monitor has a mere 1920x1090 on a much larger screen area. It's simply not capable of being as sharp as the retina. – Tetsujin Jan 22 '17 at 6:35
  • @Monomeeth El Capitan 10.11.6, MacBook Pro (Retina, 13-inch, Late 2013). – George Katsanos Jan 22 '17 at 9:48
  • @Tetsujin this would make sense if everything was blurry. Now we're specifically talking about the screen fonts. Specs say MBP Retina can drive up to 2 monitors, 2650x resolution. This is 1 monitor, 1920x resolution. – George Katsanos Jan 22 '17 at 9:50
  • Ok, so what mode are you using with the ACER R241Y (i.e. Dual Display Extended or Video Mirroring)? Or are you using the MBP in clamshell mode? – Monomeeth Jan 22 '17 at 11:06
4

The MacBook Pro (Retina, 13-inch, Late 2013) has an Intel Iris 5100 GPU and is capable of supporting an HDMI-compatible device, including 4K, while using one Thunderbolt display or it can support two Thunderbolt displays.

In terms of external resolution, this model supports up to 3840 x 2160 pixels at 30Hz or 4096 x 2160 pixels at 24Hz (using HDMI) or up to 3840 x 2160 pixels at 30Hz (using Thunderbolt).

According to the specs of the Acer R241Y, this has a maximum resolution of 1920 x 1080 at 60Hz. And, according to the user manual, this resolution is achieved using VESA mode.

Possible solutions

  1. On your MacBook Pro:

    • REFRESH RATE - As a first step, I would check the Refresh Rate set in your MBP. You can find this under the Display tab within System Preferences > Displays. If you change it, you may need to wait a couple of minutes to ensure the change has taken effect properly.
    • RESOLUTION - I would also double-check you're not using the Scaled option for your resolution. Instead, make sure you have the Best for display option selected - also found in System Preferences > Displays.
    • RESET NVRAM - It may be worth resetting your NVRAM. If you're unsure how to do this, refer to my answer here. Make sure you look under the PRAM/NVRAM heading.

NOTE: If, at any point, the display switches off after configuring options in your Displays System Preference, just press the Esc key to undo the last change.

  1. On your Acer R241Y display:

If you're still having issues after checking/trying each of the above, try the following:

  • Mode type - If your display is already in Auto mode, manually try each of the others (e.g. Standard mode, Graphic mode, etc) one by one. If it's already on a specific mode, then try it in Auto mode instead.
  • Focus - You can also manually configure the display's focus. You should be able to do this by going to the Picture Menu.
  • Reset your display - There should also be a Reset option on your display's menu. It may be worth trying this if all else fails.

[EDIT]

Since your issue is around how fonts look, there is also a setting in your System Preferences > General. Maybe try ticking/unticking the Use LCD font smoothing when available option to see what difference that makes.

  • 1
    Thank you for taking the time to write this, I had tried most of these steps before, especially looking at Display preferences (I Even experimented with installing an app that gives you access to custom resolutions and stuff). The resolution etc is correct. I think this is something with how OS/X handles font subpixel rendering. I was reading that "Sketch" had an option about that but they removed it.designernews.co/stories/64847-sketch-36 – George Katsanos Jan 23 '17 at 7:07
  • I am curious: What happens if you boot up in Safe Mode, and if you use your MBP in closed-clamshell mode? – Monomeeth Jan 23 '17 at 9:14
  • will Sketch run in Safe mode? Let me try. I begin to think more and more this is how the fonts should look like. The crispiness of Retina just can't be mimicked on an ext monitor. – George Katsanos Jan 23 '17 at 13:03
  • Well, if trying Safe Mode (I meant without Sketch, but try both) and also closed-clamshell Mode makes no difference then I would agree. To be honest, I assumed you had a blurriness issue rather than a not quite as crisp issue. It's not that you can't achieve the same crispness on an external monitor, it's just that you can't on your monitor. There are many external monitors that will display as well as a Retina screen (you just have to pay for them). :) – Monomeeth Jan 23 '17 at 22:09
  • See screenshots in main question? I'm waiting tomorrow for a 27" monitor wqhd 2560x1440.. And will compare. Frankly I couldn't imagine there would be such difference between crispness. I thought it's about color fidelity, response times.. Here the problem looks much more serious to my eyes at least. (and after googling to many other eyes as well..) – George Katsanos Jan 23 '17 at 22:16
0

I was experiencing a similar issue on an LG external monitor and just figured it out.

LG has a setting called SuperResolution+ which essentially is a sharpness filter and makes movies and pictures look better but makes text look horrible.
https://www.cnet.com/news/ces-lg-tackles-upscaling-with-super-resolution/

Switching off the sharpness filter makes my text appear perfectly.
I wonder if there is a similar feature on your monitor but in any case this answer might be useful for someone who has this issue with LG.

0

I have been having this issue on/off with an LG UM95...34 something. It's a 34 inch 3440x1440 21:9 ultra wide. Anyway, it was fine for ages and then recently went back to being what I would call... over-sharpened. It's painful to look at close up.

The last thing suggested here (reset monitor settings on the actual monitor) seemed the least effort so I tried that first et voi la! It's back to its normal smooth self. Recommend trying that first.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .