30

I'm on macOS Sierra and I have been losing icons randomly, as you can see below, the Adobe Illustrator folder does not look like it should.

enter image description here

This also occurs in the Dock:

enter image description here

FaceTime (left of iTunes) has no icon, this also occurs with numerous other applications such as Inkscape, Gimp, and a few others.

Please help!

  • Try restarting Finder ( -> Force Quit -> Finder) or using terminal to restart the dock with killall Dock. – owlswipe Jan 22 '17 at 15:27
  • And try restarting your computer, clear NVRAM/SMC, etc. – owlswipe Jan 22 '17 at 15:27
  • The restarting finder didn't work, I'll try resetting nvram – HXGamer Jan 31 '17 at 0:55

11 Answers 11

25

I had to run the below commands to make my icons come back. It took a while to find, but it finally sorted everything.

sudo find /private/var/folders/ -name com.apple.iconservices -exec rm -rf {} \;
sudo rm -rf /Library/Caches/com.apple.iconservices.store
killall Dock
| improve this answer | |
  • 1
    Did that. Fixed my missing Apple icons. I only had the icons missing for apple apps. Read Notes, Mail, etc – LukeS Oct 16 '17 at 22:04
  • 2
    Er... I think I must be doing something stupid. I put the commands in Terminal, but got 'Operation not permitted'. Do I have to set something else before doing this? Thanks in advance, Ol. – Olly Oct 18 '17 at 3:31
  • @Olly run them one line at a time. You'll need to have root permission to run these correctly. If you're the only user on your computer, the root password is likely the password you use to sign in with. – Michael Robinson Oct 23 '17 at 1:30
  • 1
    Had 70% of icons missing, it restored everything! – Toldy Jan 21 '18 at 23:43
  • 1
    Restored some icons, not all – João Nunes Mar 13 '18 at 9:07
14

This happened to me after upgrading to High Sierra - Having tried all of the icon cache suggestions without any success I booted in to "safe mode" and the problem was fixed.

  1. Restart Mac holding the shift key as soon as you hear the startup chime and hold until the boot sequence shows the Apple
  2. Log in and check the icons
  3. Restart to get out of safe mode (where many things are disabled)
  4. Log in normally and verify the icon database is rebuilt correctly under a normal mode start up

| improve this answer | |
  • thanks, just came back from safe mode, everything works now. High Sierra is so buggy. – Dongsheng Cai Dec 4 '17 at 9:28
  • 1
    Thanks a lot, that helped me as well! Side note: Hold the Shift-Key while booting your Mac to start up in safe mode. Source: support.apple.com/en-us/HT201255 – breiti Dec 4 '17 at 10:29
  • 1
    I wish there was still a startup chime! – James Paul Mason Feb 9 '18 at 15:28
  • It's worth pointing out that the reason Safe Boot works is that it empties all caches. – benwiggy Apr 28 at 13:58
7

This happened to my icons blank icons in high sierra

This was the fix. I booted in safe mode, logged in and then rebooted out of safe mode and all my icons were back. Yay!

Here's how to boot in safe mode

  1. Start or restart your Mac, then immediately press and hold the Shift key.
  2. The Apple logo appears on your display.
  3. Release the Shift key when you see the login window.

You can reboot out of safe mode by restarting and not pressing any buttons during startup. Hope that fixed your problems,

Noah

| improve this answer | |
  • The boot to save mode took quite long (~5min) but after rebooting to normal mode everything was fixed. – ulilicht Jul 11 '18 at 6:34
3

It worked for me (albeit in Mojave) by

• removing the icon from the dock, then

• opening the app and selecting the option to

• “keep in dock.”

The other options (the sudo routine with “killall Dock” at the end and booting in Safe Mode) did not have the desired result. Again, this was Mojave, but due to its simplicity, it’s worth a try in other OSes as well.

| improve this answer | |
2

The complete solution that actually did the trick was the following commands, issued in terminal

sudo find /private/var/folders/ -name com.apple.iconservices -exec rm -rf {} \;

sudo rm -rf /Library/Caches/com.apple.iconservices.store;

defaults write com.apple.dock ResetLaunchPad -bool true;

killall Dock
| improve this answer | |
1
  1. Open System Preferences
  2. Open Dock
  3. Change the Position on screen and then it back to your original settings
| improve this answer | |
  • After trying both safe mode and removing icons and adding them back, your method finally fixed the missing icons! Thank you – Lucas P. Dec 17 '18 at 11:21
1

Right-click every broken icon and select Show in Finder. Fixed it for me while the other suggestions here did not work at all.

| improve this answer | |
0

Tried a lot of commands found in several articles and nothing worked. Rebooting in safe mode did the trick in high sierra.

| improve this answer | |
  • +1 I tried running the commands in the most upvoted answer, one by one, but the first one is operation not permitted. I guess because SIP stops stuff in /var/private being deleted unless SIP is disabled. Before rebooting in recovery mode to run sudo csrutil disable, I thought I'd try the safe mode boot suggested somewhere here. Rebooting holding shift, the icons were all present and correct. Rebooting again to a normal session, and the icons remained fixed. – i-CONICA Feb 9 '18 at 12:16
0

If nothing works, still you can download the latest adobe folder icons for 2020 release and try changing it manually

dribbble.com/adobe-folder-icons-SVG-PNG

enter image description here

| improve this answer | |
-1
  1. Command Space
  2. Type Monitor and select Activity Monitor.
  3. Quit WindowServer process.
  4. Then the session is closed, enter your credentials and all icons all ok now.
| improve this answer | |
  • Didn't work. It logged me out and I logged back in. But no change :( – ecbrodie Jan 12 '18 at 19:50
-1

Force quitting all the iconservices and the Dock executables through the Activity Monitor app also worked for me. This may be a smoother experience for terminal-averse users :)

  1. Open the "Activity Monitor" app
  2. Use the search box (top right) to search for "iconservices"
  3. Select and quit(top left button ) all the icon services executables with the "Force quit" option.
  4. Use the search box to search for "Dock"
  5. Select and quit the "Dock" executable () with the "Force quit" option.
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .