2

I just got my macbook white (2009) back again from fixing (batteries were swollen), and was trying to format it to OS El Capitan. I've been trying to do that all day,

  • at first I tried with a bootable USB that I made on my on Mac (before formating for the first time). It didn't work, when I began the installation process - after formatting my MacOS drive, an error occurred. Ok, I was kind of expecting that.
  • the second time, I had already formated my HDD, so I made a bootable USB from my Windows 10 PC, using "TransMac".
  • I dind't work this time, and the next. The error is: I plug the USB, Mac iniciates and while I'm pressing the "Option" key, it only shows the USB drive, and when I click on in to begin the install/format, the "blocked" sign appears and it stops there, on that loop.

edit: This is what happens when I turn on the computer holding the option key (with the USB plugged in):

  1. My MacOS drive doesn't appear, only the USB.
  2. When I click on the USB, it begins to load (I couldn't load all images).
  3. Then, when the bar loads, the "blocked" sign appears.

My MacOS drive doesn't appear, only the USB. When I click on the USB, it begins to load

Then, when the bar loads, the "blocked" sign appears.

  • After formatting your drive, an error occurred and you were expecting it?? What was the error? Why would you be expecting it? This is a kinda critical piece of info we need to assist! – Allan Jan 21 '17 at 2:50
  • when i was making the bootable usb on my mac, it turned off when it was in the 'final touches' let's say 98% (i was using disk marker x). so i was expecting (maybe), some error. the error was that the file wasn't complete, something like that. – viviane Jan 21 '17 at 2:53
  • If I understand you correctly, it was the creation process of the USB drive that generated the error, not the formatting of the drive, correct? If this is the case, you need to get a new USB installer made. The prohibited sign indicates that the file system on the USB is corrupt. – Allan Jan 21 '17 at 10:47
  • Ok, I will try to fix that. But another worry that I have is: why my MacOS drive won't appear? – viviane Jan 21 '17 at 18:04
  • Your MacOS drive doesn't appear because you erased it (first bullet point in your question). It's seeing the USB because the boot loader is fine. You're seeing the prohibitory sign because the files are corrupt (most likely because it only made it 98% of the way). What you need is a good USB installer to do a clean installation. – Allan Jan 21 '17 at 18:12
1

First of all, like Allan mentioned in the comments, your MacOS drive will not show up on startup if you erased it. The reason the 'blocked' sign appears is because the installer files for OS El Capitan are corrupt on your USB.

I also have a white MacBook from 2009 and I encountered the same issues when trying to install macOS Sierra from a bootable USB.

Here's what you can do:

  1. Re-create a bootable USB of OS X Yosemite using a Mac computer running MacOS. From my experience, third party applications like Install Disk Creator work better than the Terminal for fully loading the boot files. Note that the USB storage size must be larger than the file size of the installer for the OS you want to install. (8GB worked for me)
  2. Run the bootable USB on your MacBook by using the steps you did before. This time, you should be able to get pass the 'blocked' sign.
  3. Format the HDD using Disk Utility from the Utilities Menu. Click the 'Erase' tab and set the format of your HDD to 'OS X Extended (Journaled)', then click erase. Your MacBook should then be able recognise the HDD.
  4. Install the OS X Yosemite on the HDD using the OS X Installer from the Utilities Menu. You can always update to El Capitan after you install Yosemite. You may have to configure the system time if you run into an error while validating the install.
0

So you can boot from the USB drive, correct? If so, select the Disk Utility in the menubar and wipe your internal disk. Make sure to select "Mac OS Extended (Journaled)" and "GUID Partition Map" as described here.

It is possible that your Mac is not compatible with OS X El Captian. Apparently you need at least an "early 2009" model. Did you check the System Requirements? If this is the case you can try some workarounds to get Sierra to run on your Mac.

  • No, I can't boot from the USB drive, when I select the USB to begin the installation, it loads (with the mac logo and the bar), then what appears is the prohibitory sign. And I upgraded my mac, new HDD, memory ram, memory... So when I saw the system requirements for El Capitan, it "fit" – viviane Jan 21 '17 at 16:45
  • @viviane I believe this is what happens if your mac is not compatible to this version of OS X – n1000 Jan 21 '17 at 16:47
  • I'll try another OS X version, then.. – viviane Jan 21 '17 at 18:05
  • @viviane also check the 3rd link in my answer. it might apply to your case. – n1000 Jan 21 '17 at 18:24
0

So when you see the 'blocked sign' (also known as the 'prohibitory sign', 'no entry sign' or 'circle with a line through it') what your Mac is telling you is that it cannot locate a drive with a bootable partition. What this means is that whatever drive the Mac was trying to boot to is either missing a critical boot file or it is damaged (and it either couldn't find another drive to try or it did but that one failed as well). Since you specifically selected the USB drive in an attempt to get it to boot, we know that it is in fact the drive it was trying to boot to. Long story short, your Mac is telling you that the "Bootable USB Drive" you created is not actually bootable.

Some suggestions:

  • Complete an SMC Reset & a PRAM Reset and then try the bootable USB drive again
  • If issue still occurs, try to re-create the bootable drive again using the resources you have as it may have experienced an issue/error that wasn't reported to you the first time; then attempt to use the 'new' bootable USB drive again (alternatively, you could try something other than TransMac in case it was the problem)
  • If it doesn't work, verify that the Mac still doesn't have a Recovery Partition option from the Boot disk selection screen (boot holding 'option' key). Unfortunately 99% of Macs from 2009 or earlier don't have the Internet Recovery option no matter which OS they've been upgraded to.

If you have the original install discs that came with your Mac (or a retail version of Snow Leopard), this is where I'd resort to them because my next recommendation can be a headache (or you may simply not have the resources handy). I know it means starting from either Leopard or Snow Leopard and then upgrading, but it would be the easiest and cleanest way to move forward.

If you don't have the original install disc or a retail copy of Snow Leopard, proceed.

Use this section if your Macbook has a firewire port (Early or Mid 2009 model)

If you have access to another Mac you could attempt to put your empty Mac into target disk mode and reformat it using Disk Utility from the functioning Mac (booted normally, not to a Recovery mode). Then you could try to run the El Capitan installer right from there (after placing a copy of it into the /Applications folder), and select your Mac's internal drive as the install destination when prompted. You will need an App Store downloaded copy of the OS installer you're trying to install though, so if you don't have a functioning one you're going to need a solid internet connection to download one.

Apple article for Target Disk Mode: https://support.apple.com/kb/PH22135?viewlocale=en_US&locale=en_US (You will need just a firewire cable if the second Mac has a firewire port; you will also need a Thunderbolt to Firewire adapter if that Mac is too new and does not have a firewire port and instead has a Thunderbolt port)

Skip to this section if your Macbook does not have a firewire port (Late 2009 model)

If your Mac - for whatever reason - will not boot into Target Disk Mode, you could purchase (or borrow) and external drive enclosure, remove the hard drive from your Mac and install it into the drive enclosure, and then plug it in to a functioning Mac via usb. From there you would follow the same steps that I provided for Target Disk Mode - without booting into Target Disk Mode and instead just mounting the drive like a regular external HD - to format and reinstall.

  • Ok, I will try all of that. But, another worry that I have is: why my MacOS drive won't appear? – viviane Jan 21 '17 at 18:05
  • Your first paragraph is wrong. The prohibitory sign means that the files are corrupt. A flashing folder means it can't find a bootable partition. The OP's first pic is of a bootable USB meaning it found the bootable partition. – Allan Feb 4 '17 at 13:22
0

Your macbook 2009 (even early 2009) can handle El Capitan, but not Sierra. The USB stick is not good. Make a new one on a working mac with ElCapitan.

0

"But, another worry that I have is: why my MacOS drive won't appear? " Because it is not bootable with an OS. You only see the bootable drives in the boot menu.

0

Problem: You have no bootable media.

  1. The USB installer didn't complete thus making it "corrupt" and non-bootable. This is why you see the USB as a boot device, but then you get the prohibitory sign when you try to boot from it. The USB has a boot partition and the boot files exist, but the files are corrupt.

  2. The internal drive was wiped clean (formatted) rendering it blank and non-bootable as well. This removed the boot partition and the files so since they can't be found, the drive doesn't show up as a boot option.

How to fix.

You need a working installer. Period. No amount of resetting the SMC or NVRAM is going to make a non-bootable USB installer suddenly bootable.

First off, let's confirm that El Capitan is compatible with your Mac. Per Apple Support, it is:

  • MacBook (Late 2008 Aluminum, or Early 2009 or newer)


The next step is to create a new USB installer. There are many excellent answers here on SE that already address this, so I won't belabor that point here. Take some time and read the answer to this question for details on how to do this.

How to obtain the El Capitan Installer.

This is the crux of the matter. There are several ways to obtain the El Capitan Installer:

  1. Visit your local Apple Store. They will assist you in downloading the installer for you. In fact, they may already have the installer created and will install the OS for you while you wait. (This would obviously be the preferred method)

  2. Download the installer from a friend with a Mac. You can still download the El Capitan Installer. If your friend downloaded it previously, it can be re-downloaded and installed. This can be done by either creating a USB installer or connecting your Mac in "Target Disk Mode". (For this, you will need a Firewire cable)

  3. Purchase and install a Snow Leopard via Install Disk (available on eBay or the Apple Store). Once you have SL installed, you can upgrade to El Capitan via the App Store

  4. I am NOT going to recommend that you could download and create an the Snow Leopard disks via bittorrent and do the installation and upgrade that way because this would be outside the scope... If you must install via a PC, don't create the USB. Burn an ISO (CD/DVD image) of SL and install that then upgrade to El Cap.

Lessons learned.

First, before you erase your drive, make sure you have a working USB installer. You can boot the installer without actually committing to installing the software. You are just making sure it boots. If it boots, it works.

Secondly...allow your installation of whatever you are doing (like creating the USB installer to finish). 98% is not 100% no matter how close it seems.

Finally....this has been said countless times: Backup. Backup your backup. Time Machine is your friend.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .