2

I did a dumb thing while messing around with Boot Camp and managed to lose a partition that I had made earlier to install Windows on to.

A 300GB partition is now missing and I've tried everything since this morning to get it back but I clearly lack the knowledge and I need my Mac for school work.

Do you have any suggestions on how I can restore the lost partition without a backup?

Thank you!

    diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            699.4 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         24.0 GB    disk1
   1:                        EFI EFI                     314.6 MB   disk1s1
   2:          Apple_CoreStorage Macintosh HD            23.6 GB    disk1s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk1s3

/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            Macintosh HD           +722.0 GB   disk2
                                 Logical Volume on disk1s2, disk0s2
                                 9449131B-67F8-4D97-82D6-F2BDEDB48B6C
                                 Unencrypted Fusion Drive




diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group CF679B40-3999-4A00-AA41-4D7CC546FB41
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         722905776128 B (722.9 GB)
    Free Space:   106496 B (106.5 KB)
    |
    +-< Physical Volume BF1C586C-AECF-4640-90A3-EF1F1B1B1776
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk1s2
    |   Status:   Online
    |   Size:     23553724416 B (23.6 GB)
    |
    +-< Physical Volume 7018B90D-8378-4015-A9F5-B531B325FABE
    |   ----------------------------------------------------
    |   Index:    1
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     699352051712 B (699.4 GB)
    |
    +-> Logical Volume Family 9AD3A7A0-D9E3-4A3F-B233-7EACB65C38BC
        ----------------------------------------------------------
        Encryption Type:         None
        |
        +-> Logical Volume 9449131B-67F8-4D97-82D6-F2BDEDB48B6C
            ---------------------------------------------------
            Disk:                  disk2
            Status:                Online
            Size (Total):          722000936960 B (722.0 GB)
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
            LVG Type:              Fusion, Sparse

Storage

  • When you say you "messed around with BootCamp and managed to lose a partition" can you be more specific? As in, did you accidentally unmount the partition and can no longer get it to mount? Did you accidentally erase the partition using Disk Utility? Write over the partition (maybe using the BootCamp Assistant thinking you were creating a second one or just repairing something on the original partition?) Determining how the partition was 'lost' will dictate how to move forward and what can be done, if anything. – NYKg Jan 20 '17 at 21:15
  • Thanks for responding! I used Disk Utility to erase the Boot Camp partition then tried to restore it back to a single partition. After hanging for about 5 hours in Disk Utility on "File system check exit code is 0", I followed some advice to restart the machine and try again. This is the point when the erased Boot Camp partition dissapeared. – Will Jan 20 '17 at 21:16
  • From my research, I've seen a number of methods (repair CoreStorage, etc) but I don't want to make another mistake. Thanks again for any advice. – Will Jan 20 '17 at 21:26
  • Hi klanomath. Essentially, I made a 300GB partition using Boot Camp on my 1TB drive to install Windows. I then tried to restore it back to the single partition to clean install Sierra with a new copy of Windows 10 I purchased (being a perfectionist has its downsides!). – Will Jan 20 '17 at 22:27
  • I made a mistake somewhere down the line and the partition doesn't show up at all anymore -- which I didn't intend! Hope that's clearer. I've added an image of the storage to help. I need the lost partition back because I use Windows to run design software such as Maya and Revit for my architecture studies. – Will Jan 20 '17 at 22:29
0

Your Windows partition isn't missing after erasing it! You gained some unallocated disk space.

To reinstall Windows with Boot Camp Assistant you have to restore the ~vanilla Fusion Drive state. You can try to resize the whole Core Storage stack with the command with: diskutil cs resizeStack lvUUID size. In your case that's:

diskutil cs resizeStack 9449131B-67F8-4D97-82D6-F2BDEDB48B6C 1022g

If you get an error "... not enough space ..." choose a slightly smaller size like 1021500m or 1021g.

After poking around with Disk Utility or the Windows Disk Management tool (e.g. trying to remove/resize a Boot Camp partition with Disk Utility) the resizeStack command often fails with a cryptic -8xxxx error message because some internal CoreStorage structures are corrupted. Your OS X volume usually isn't affected though.

Then you have to either backup the OS X partition with Time Machine, rebuild a vanilla Fusion Drive and finally restore the TM backup or install OS X from scratch after rebuilding a vanilla Fusion Drive.

Then you can launch Boot Camp Assistant and install Windows 10 again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .