3

I am currently having an issue with Xcode 8.2.1 not being able to activate developing on my iPhone 7 Plus (on iOS 10.1.1). Whenever I try to deploy an application, it gives me the following error:

An error was encountered while enabling development on this device. Please try rebooting and reconnecting the device. (0xE8000076)

In the iPhone's console, I found the following errors:

Does anyone have an idea what I could possibly do to solve this issue? Any solutions I have found so far did not work at all. And yes, I did already try rebooting and reconnecting multiple times.

  • Try switching out your cable for a genuine Apple cable? – owlswipe Jan 21 '17 at 2:04
  • @owlswipe I am actually using the original Apple Lightning cable that came with my phone. Also I don't see how an alternate cable would have anything to do with the error shown in the console. – nguoy_tk Jan 21 '17 at 11:23
  • And have you tried the official suggestion of "rebooting and reconnecting the device"? – owlswipe Jan 21 '17 at 15:22
  • @owlswipe And have you tried to read my question in its entire form? If you don't bother reading the question, please refrain from answering. – nguoy_tk Jan 21 '17 at 15:23
  • Oh, my bad! How about: "For me, it had been set up in iTunes months back, but after opening up iTunes, selecting the device, and rejecting the prompt to upgrade it, only then would Xcode's Devices Organizer start re-downloading Symbol Files, and eventually it worked." stackoverflow.com/questions/32658727/… – owlswipe Jan 21 '17 at 15:35
3

Maybe you forgot to register your device with your develop account? I got that error code (0x8000076) when I forgot to register it. To double check:

If it is missing, create a new entry.

  • Indeed. The steps for an ad hoc Apple ID are different than a registered developer. Great suggestion and possible solution. – bmike Dec 17 '17 at 18:02
0

Those versions are not code signed anymore.

  • Update Xcode
  • verify or clarify if your code signing is going to be ad hoc or with a paid developer account
  • update the iOS device
  • verify the device is paired using Apple Configurator 2 and the command line tools or console app to inspect the system logs on the iOS device from the Mac.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .