The Terminal app is slow at reacting to input, lag is very noticeable when I press and hold Enter. When I type bash to create a sub-shell it becomes much faster.

I believe this behavior started when I updated to Sierra, but I might be wrong.

Does anyone know why this happens?

  • Do you have any logs or error messages in the console when you open Terminal? This could help diagnose the problem.
    – bret7600
    Jan 21, 2017 at 18:47
  • Have you ruled out the obvious issues like high IO load or high CPU load? Running iostat 5 for a while in one window will show you increasing CPU load - summary of load average - and most importantly if tps - io transactions per second is high. Those will always impact performance.
    – bmike
    Sep 30, 2017 at 13:21

6 Answers 6


After upgrading to High Sierra, I also noticed that there is some lag in Terminal.app after pressing Enter. I was able to fix it by doing this:

  1. Go to Preferences > Profiles > Shell
  2. In the "Run Command" box, write login -f <username> (replace <username> with your username)
  3. Uncheck "Run inside shell"

I suspect that Terminal.app tries to integrate with the shell somehow and running bash indirectly fixes that.

  • Thanks! Worked great! Iterm2 is still very slow though and I haven't been able to apply this solution to that app yet
    – selle
    Mar 15, 2018 at 13:28
  • 2
    What is going on? Can you into more detail?
    – Mark A
    Jul 1, 2018 at 23:18

I noticed the same effect on Sierra. I discovered a simple solution: the response time improved when I decreased Scrollback (in Terminal>Preferences>Window) from "limit to available memory" to "limit of number of rows to (200 or whatever)"

  • Although this solution works it looses fuctinnality I use a lot.
    – William
    May 6, 2017 at 15:25
  • It's still extremely slow after this solution for me, but definitely noticeably faster than it was. Thanks for the tip! Jun 1, 2017 at 19:13

I switched to Iterm2 about a month ago. It has no noticeable lag for me, especially after High Sierra.

  • Welcome to Ask Different! This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – Tetsujin
    Sep 30, 2017 at 15:50

I have been troubled by slow terminal since upgrade to Sierra for quite long time. I've tried all of above solutions, but sadly none of them ease the problem.

At least on my mac, that slowness was found caused by the transparency of terminal app background. Once turned off transparent background, terminal got full speed back.


I noticed that Crowdstrike Falcon slows down my MacOS terminal significantly (regardless of OSX/MacOS release) for simple things like 'git status'.

As per MIT Confluence page on CS Falcon:

To disable CS Falcon, you can sudo /Library/CS/falconctl unload

To remove CS Falcon, you can sudo /Library/CS/falconctl uninstall


When installing the Telnet program, the speed became faster.


  • 2
    This makes no sense whatsoever. Additionally, the link is to a blog that provides a walk through of how to install telnet, not a fix for the OPs question.
    – Allan
    Nov 14, 2017 at 14:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .