5

I was accidentally able to turn on touch bar zoom, which apparently casts the touch bar and your actions to the bottom 1/2 of the screen. Now there is no longer an option to disable it in the 'zoom' section of 'accessibility'. As this is a new feature, there is no documentation of this issue yet.

I would appreciate any help, as this makes the the touch bar near useless.

6

I got it to work.

Selecting the "System Preferences" from the top left "Apple" icon or just clicking the "System Preferences" icon directly both result in the "Enable Touch Bar Zoom" checkbox NOT showing up.

The only way to consistently get it was to right click or click and hold on the "System Preferences" icon found in the dock, then select "Accessibility", then select the "Zoom" tab.

No idea why it's any different, but it is.

| improve this answer | |
  • 1
    I was puzzled as well. I just toggled it ON and next time I entered that dialog it wasn't there anymore. Had to re-dock my System Preferences (start System Preferences, right-click icon in dock, tap Options then "Keep in dock") and start System Preferences from the dock to get the checkbox shown again. – Peter Theill Feb 3 '17 at 22:41
  • This is insanity. Also the suggestion doesn't work for me. There's gotta be a way to set this via oneliner in Terminal, but I don't know how to find out. – Trevor Hartman Mar 11 '17 at 18:28
  • I was able to uncheck it after opening Accessibility about 20 times various ways. – Trevor Hartman Mar 11 '17 at 19:02
0

I kept trying the solution mentioned by J Track with no avail, yet after long trial and errors I was finally able to have the checkbox reappear by trying to edit the Universal Access plist then opening System Preferences (preferably from the dock):

plutil -replace closeViewDFRZoomEnabled -bool false ~/Library/Preferences/com.apple.universalaccess.plist

Strangely, even though the command should set this property as false, I found the property still checked in the UI, but at least I was able to turn it off again. (possibly due to combination of notes 2 and 3).


Note 1: You can view the zoom-related properties in the plist file using

plutil -p ~/Library/Preferences/com.apple.universalaccess.plist | grep -i zoom

Note 2: Give 2-3 seconds between each step.

Note 3: If the above method doesn't work you may try to kill any instances of the cfprefsd as this comment suggests.

Note 4: I suspected the closeViewDFRZoomEnabled may be the right property by changing the TouchBar zoom level and watching the value closeViewDFRZoomLevel change.

Note 5: Tested on macOS Sierra 10.12.3

| improve this answer | |
  • The UI doesn't change because those values are now cached, and you have to use defaults write com.apple.universalaccess closeViewDFRZoomEnabled -bool false instead. – Iulian Onofrei Mar 8 at 13:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .