11

This has been irritating me for a long time and I have not found a solution for this whenever I have looked for one.

This problem has perplexed me maybe as far back as Mac OS X 10.7, but I can't be sure. We share a couple of Macs in our family of five and because of that we each have dedicated user accounts. In total that's five separate user accounts. After booting up we get the login window just fine. However, the only way to select the user account you wish to log in to is to click on the user's name. In the past we could just press the first letter of our username and that would automatically select that user for you. But this hasn't happened for a long time now.

The reason why I think it may not have occurred since Mac OS 10.7 is that one of our Macs is still on Mac OS X 10.6.8 and on that particular Mac we can still press the first letter of our username to select that account. The Mac this doesn't work on is an iMac using Mac OS X 10.11.6, but like I said, this has been happening for a long time, even before Mac OS X 10.11. It's not the end of the world, but it's surprising how annoying this is for us.

MY QUESTIONS:

  • Did Apple remove this feature for some reason?
  • If not, is there a setting anywhere to switch this feature back on?
  • What happens when you first press the TAB-key in the login window? Also please check the left/right arrow keys. If nothing happens, press Control+F7 to turn the "Full Keyboard Access" on/off. You may need to press FN+Control+F7 to enable it on your keyboard. – oa- Jan 19 '17 at 10:22
  • thanks for your help. I tried all those options and nothing happens with any of those keys. turning full keyboard access on and off makes no difference either. – mada.eve Jan 19 '17 at 13:18
  • Try this: In Terminal past this. It will back up your .GlobalPreferences.plist file and delete it. This file may prevent the keyboard from working. (1) defaults write com.apple.finder AppleShowAllFiles YES (2) killall Finder (3) sudo cp /Library/Preferences/.GlobalPreferences.plist /Library/Preferences/.GlobalPreferences.plist.bak (4) rm -f /Library/Preferences/.GlobalPreferences.plist defaults write com.apple.finder AppleShowAllFiles NO (5) Reboot your Mac and try to select a user account. – oa- Jan 19 '17 at 13:31
  • 1
    I tried doing this but it didn't work. actually it did do something (finder quit, hidden files are no longer hidden), but it didn't solve the login window problem. the first letter still doesn't work, nor does the tab or arrow keys. thanks for trying though. :) – mada.eve Jan 20 '17 at 8:48
6

Did Apple remove this feature for some reason?

No, this has not been removed. You should still be able to select users at the login window via the first letter of their user name, or via using the tab and arrow keys.

If not, is there a setting anywhere to switch this feature back on?

At the outset let me say this may not be the likely solution for you. However, I have seen this behaviour and thought it was worth mentioning in case it helps you or others.

If your Mac running El Capitan is a desktop Mac (i.e. iMac, Mac Mini, Mac Pro, etc) and it happens to be plugged into a UPS (i.e. an Uninterruptible Power Supply), then shut down your Mac and unplug it from the UPS. Now plug it into another AC power outlet and reboot it. Check to see how your login window behaves now?

If on the off chance this is your situation and your Mac now works as you'd like, an option that may help you is upgrading your OS to macOS Sierra. I say this only because macOS Sierra offers some native support for using a UPS and this may or may not rectify this issue.

  • Well it IS an iMac and it IS plugged into a UPS, so maybe you could be right. But I've had this issue since before El Capitan so it's not new to El Capitan. And why would it make any difference what AC power outlet the computer is pugged into? It makes no sense to me. But since my iMac IS plugged into a UPS, I will try what you said right now. – mada.eve Feb 1 '17 at 7:12
  • Agreed on all counts. I didn't mean to imply it was an El Capitan issue, I was just using that as a point of reference to identify the Mac you were having problems with (as you said it had Mac OS X 10.11.6 installed). How long have you had it plugged into a UPS? I'm guessing a few years (enough to span different generations of Mac OS X). – Monomeeth Feb 1 '17 at 7:18
  • As to why it would make any difference what AC power outlet your Mac is plugged into, I honestly have no idea. It makes no logical sense to me at all! At least not in terms of affecting something like this. Also, for the record, I don't know that installing macOS Sierra will help. That is just a guess on my behalf as something worth trying, just because it does have UPS settings in System Preferences. – Monomeeth Feb 1 '17 at 7:19
  • This is ridiculous! I did what you said and IT WORKED! This is unbelievable! :) Just for the record, I only had the iMac plugged into the AC outlet on the UPS, I didn't have it connected any other way (not USB, not Ethernet). So it was just the power cable. And removing it worked! I just can't believe this! :) I'm sorry to say that I can't install Sierra onto this iMac, so I guess it's back to not having the login window work how I want. It's just not worth the risk (we have blackouts all too regularly here). Thanks for your help though! I'm no longer going mad! lol – mada.eve Feb 1 '17 at 7:30
  • And yes, been using a UPS for a few years, so that explains the timeline as well. :) – mada.eve Feb 1 '17 at 7:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .