20

The bluetooth keyboard on my iMac seems to work for a while then starts to skip letters or mix up letters while I am typing. It seems there is also a delay between the time I type a character and when it shows up on screen. I've switched to my wired keyboard and the same thing happens. If I reboot, the problem goes away for a while, then comes back. Any suggestions?

3 Answers 3

19

For macOS Monterey and later:

macOS Monterey and later don't have factory reset options. In macOS Sonoma, macOS Ventura, and Monterey, you can use Terminal as an alternative method.

  • Open Terminal via Spotlight.
  • Run this command: sudo pkill bluetoothd

Some times you need to restart your mac.


For macOS Big Sur and earlier:

  • Hold down the Shift and Option keys ('Alt' on some keyboards) and, at the same time, click on the Bluetooth icon in the menu bar.
  • Find your keyboard on the device list and select "Factory Reset"
  • Confirm "remove" when prompted.
  • Reconnect keyboard.

I tried "resetting NVRAM and SMC" as Apple Support mentioned but didn't enough to solve. If the solution above doesn't solve the problem, please try to reset NVRAM and SMC before following the solution steps.


Additional Info for new MacOS: There is no "Factory Reset" option for a specific device in the latest macOS (I'm not sure when it changed). You can use the "Factory reset all connected Apple devices" option after the first step.

9
  • 4
    Boom. Factory reset of the keyboard fixed it for me. Man you're a life saver - it was deriving me nuts. I went through closing a bunch of Safari tabs thinking the /computer/ was running slow, until I tried the laptop keyboard and realised it was the bluetooth keyboard's fault - sorry Safari, I take it all back! ;) Commented Jun 26, 2020 at 11:53
  • 1
    I have an almost new 27" iMac. Keyboard was laggy and seemed to go in spurts of 3. Did the keyboard reset, and it is now working without lag. Thank you ali6p.
    – mmm
    Commented Nov 14, 2020 at 4:37
  • 1
    Always critical of fixes that ask you to reset or restart something, but boom! This was the only one that worked. Thank you!
    – Navid Khan
    Commented Apr 5, 2021 at 10:04
  • This did not work for me (macbook air 2021). I bought a logitech keyboard and that even had the same problem when connected via bleutooth. The problem was solved when I connected via the logitech thingy.
    – Hans Dash
    Commented May 12, 2021 at 18:33
  • @HansDash I had the same problem with Logitech's mouses. I had to use unify dongle to connect a bluetooth mouse! This is frustrating... I'm not sure if Apple or Logitech is responsible for this.
    – ali6p
    Commented May 13, 2021 at 22:56
6

Apple says the following:

You may have accidentally set an option that changes how your keyboard operates.

Choose Apple menu > System Preferences, click Accessibility, then click Keyboard. Make sure Slow Keys is turned off. If Slow Keys is on, you must hold down a key longer than usual before it’s recognized.

If the problem persists, enter "Safe Mode" to bypass all third party system extensions and only load the required system components. This should help you determine whether third-party software is to blame for your situation.

If you google "Apple HT201262" you will find the article describing how to do this (I can't refer to 2 links/articles yet, sorry!)

Would you still face these issues in Safe Mode, then my final advise is to contact Apple directly.

0
5

Apple's solution of resetting NVRAM did not work for me either. I fixed this by going to System Preferences -> Keyboard -> Input Sources -> Set Up Bluetooth Keyboard. I disconnected my keyboard there, switched off the keyboard, turned it on, and reconnected the keyboard. Then the problem disappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .