1

I just upgraded to iOS 10.2, and now when I send a message to my niece (who has her WiFi and Mobile Data off, but Voice+Text Cellular on) it always goes as iMessage instead of auto-sending as an SMS as it used to. She then does not get it until she turns on her data.

This only happens with my niece who has an old iPhone 4. She is unable to upgrade to iOS 10, so maybe that has something to do with this issue? It was fine prior to me upgrading to iOS 10.2 (messages to her when she had data connection were sent as SMS so she used to actually get them when offline). When one of my friends—who has iOS 10.2—has no internet connection, messages to him are sent as SMS automatically so he actually gets them. How can I get messages to my daughter to send as SMS automatically when she's disconnected from the internet but not from calls and texts?

I have enabled Send as SMS when iMessage is unavailable.


tl;dr by owlswipe: Messages to my niece's iPhone when she's disconnected to the internet but connected to voice + text used to automatically send as SMS instead of iMessage, but they no longer do. How can I restore the old behavior?

  • Are you sure that the messages are being addressed to the phone number and not to her AppleID email address? Maybe creating a contact with just the phone number might make it easier to ensure the two are not getting substituted for each other. – j-beda Jan 19 '17 at 3:21
1

It sounds like the Messages app thinks that a device signed in with your niece's Apple ID is connected to Wifi or the internet, whether this be the case or not. Is there a chance that she's used her Apple ID to sign in to the Messages app on a Mac? If so it could be receiving her iMessages, thus circumventing the 'Send as SMS when iMessage is unavailable' because technically a device capable of receiving those iMessages is 'available'.

If that's not the problem, these steps have worked for me in the past so I'm hoping they'll also work for you! (You will likely need your Apple ID and password to sign back in to iMessage when you're finished.)

  1. Disable 'Send as SMS when iMessage is unavailable'
  2. Turn off iMessage altogether on your phone from 'Settings > Messages' (the main/first slider)
  3. Restart your phone
  4. Turn iMessage back on from 'Settings > Messages'
  5. Sign back in with your Apple ID if it has been removed
  6. Enable 'Send as SMS when iMessage is unavailable'
  7. It wouldn't hurt to follow these steps on the iPhone 4 as well, as there is a chance the problem is on her end and not yours (Since you haven't noticed the issue happening with any other contacts using Apple devices).

These steps didn't cause any problems for me personally with my stored messages within the Messages app, but as always before doing any troubleshooting backing up your device is a smart move! I did not design iOS so I cannot absolutely guarantee no side effects!

  • Perhaps your neice should also double-check all her devices (macOS and iOS) and make sure that in Messages.app the preferences are set so that "you can be reached for messages at xxx-xxx-xxxx" is unchecked. i THINK (but I am not sure) that when this is unchecked, other people will not be able to send you internet iMessages to that number, and instead SMS messages will be the only way that the number can recieve messages. – j-beda Jan 19 '17 at 3:19
0

Apple has done an inadequate job integrating iMessage and SMS. Works in most cases, but not well enough to be a reliable means for critical communications.
To bypass iMessage and use SMS reliably, go to Settings > Messages and turn off iMessage, then send your message.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .