1

My laptop (MacBook Pro late 2012 running OS X 10.10.5) has had an issue the last two mornings. When I turn it on I get a load of notifications saying that I need to re-enter the password for my internet accounts.

Digging a little deeper what has happened is the 2 factor auth passwords used for Mac Mail Gmail accounts have all been lost. Any ideas why this keeps happening overnight and what I can do to prevent it?

I've tried going to System Preferences > Internet Accounts and updating the passwords used to a Google app specific password (the system Google uses to get around applications that don't support their 2 factor auth) but when I do this it insists that I use a 2 factor login.

0

I had the same problem. I updated to Sierra and then Mail kept asking for password but did not help when I re-entered them. I dug deeper and found the ports needed to be corrected (in Mail Preferences). Did that and it works now.

0

I was able to resolve the issue by:

  1. Going into Keychain and deleting all of the Google auth tokens for all of my Google apps for business and Gmail accounts.

  2. Delete one of the internet accounts completely
    (I don't think this step is essential but it's what I did)

  3. Restart the machine

  4. Re-add the account I deleted, re-populate the passwords for the accounts that were missing them.

This seems to solve the issue temporarily as I haven't had it reoccur for a few days, but after a month of working fine, the issue has come back. Running through the steps again worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .