1

Okay, so I've spent almost the entire last day on this problem, and I've googled the crap out of it, I hope someone here can help me.

First off: Yes, I've cleared the NVRAM/PRAM several times and I've reset the SMC more than once too.

I have a setup with two displays on my desk that are connected to my desktop PC. I sometimes used one of those displays with my MBP via HDMI. A couple of days ago, I've decided to use both of those with my MBP and an external keyboard/mouse just to have a more tidy experience on my desk.

So I got two DisplayPort to HDMI cables to realise this extravagant folly.

Now, when I plug either of them in, nothing happens.

The (internal) display will flicker for a second, but the external displays are not detected. Neither via the old "hold option and click detect displays in Preferences->Displays" nor via "put Mac to sleep and wake it up". I've cleared the NVRAM and reset the SMC several times. I've booted up in safe mode and tried it. No dice. They don't show up in the system information box either.

To be clear, I'm not trying to connect both displays at this time. Neither of them works with neither cable.

The cables are not faulty, as I've tried both cables and both monitors with my MacBook Air Mid 2011, and they work just fine in all possible combinations.

Both displays work just fine with the MBP directly via an HDMI cable or with my mini DisplayPort->VGA adapter.

So, surely, it must be some software issue.

Now, I've tried to use one of those hellish cables to connect my MBP to my TV, and --voila-- it worked. So my MBP is indeed capable of using those cables.

So, I've ruled out

a) the cables

b) the displays

and c) the notebook as a source for my woes.

Neither is it the combination of a & b (works with MB Air), a & c (works with TV), or b & c (works via HDMI and mDP->VGA).

What am I missing?

Here's the displays, sorry for not including them in the original post:

  • BenQ XL2411
  • Samsung SyncMaster P2770

The TV that for some reason works with the cables and the MacBook is a Panasonic TX-32ASW504. I'll try and go around town and plug my Macbook into other people's HDMI to test out other displays.

I'm running macOS Sierra 10.12.2 on a MacBook Pro Retina 13'' Mid 2014.

  • One of the key bits of information we need to try and help you troubleshoot this is the actual brand/model of your displays. Can you please update your question to include this info. – Monomeeth Jan 19 '17 at 5:14
  • Man, this is sounding like you need Janie Porche!. Have you seen this thunderbold wikipedia page?. It talks about different Thunderbolt version support for different DisplayPort versions. Could this be a drivers issue? – radarbob Jan 19 '17 at 15:51
  • I am having this same problem with a mid-2014 Retina display MacBook Pro 15" when trying to plug in a 24" Cinema Display monitor using the built-in mini display port plug. Did you find any answers? I've tried all the steps you described above and know that a late-2013 13" Retina display MacBook Pro running the exact same OS (Sierra, 10.12.5) work with the external monitor just fine. The MacBook Pro screen flashes when I insert the mini display port plug but it doesn't recognize that it's a monitor for whatever reason. – superchristopherism Jul 17 '17 at 1:58
1

So it looks like you have systematically ruled out all hardware issues on all components, so you're right and it sounds software related. And since you were using at least one of the monitors before, it's likely not a compatibility issue.

Just in case, I would connect an external monitor (even though it appears unusable) and then check for software updates in the App Store - maybe there's a necessary firmware update to install that has yet to be triggered.

What I would do next is to test the issue in a new user account - if it happens there, it's a system-wide issue. If it doesn't, the problem could be with a corrupt system preference file somewhere in your user library that needs to be regenerated. If you have a backup from before this issue occurred, restoring your user's home folder from the backup would actually be the quickest and easiest solution to this problem, as hunting down individual preference files can be tedious when you don't know the exact one causing the issue.

If it's a system-wide issue, it's likely OS related not system library .plist related as you still had the same issue in safe mode. (Although if the monitors are identical it could be a driver issue and I would check the manufacturer's website for new drivers, but if they're different and both are not working that is highly unlikely.)

Next I would back up your system and then reinstall the OS from the App Store to see if that fixes it. I know that's time consuming but I usually set mine up before I go to bed and it's done long before I wake up.

Last but not least is an Erase and Install from the Recovery Partition, but let's hope it doesn't come to that!

  • Hey, first of all thanks for your help! Unfortunately, it still persists if I create a brand new test user. I'm somewhat reluctant with resetting my machine to a former state, I only have a time machine thing from about 9 months ago. Also reinstalling I'm not a big fan of since it always takes a while to configure a machine quite right, and install software that you need (i.e. random latex packages etc.) So, it seems to be system wide anyway. I've tried deleting the display*.plist files in ~/Library/(and so on) & /Library/(and so on) but no luck. :( – tugi Jan 18 '17 at 18:47
  • Narrowing it down to a system-wide issue rules out anything in the ~/Library at least, and unfortunately I've examined all of the preference files I could find in the system library and cannot find one containing anything pertaining to external displays. Just as a reminder, reinstalling the OS from the App Store does not touch any user preference files or previously installed applications as it simply removes the OS and replaces it with a new copy. I would still recommend backing up first though. – NYKg Jan 19 '17 at 0:58
  • So I did the re-install from the App Store, didn't help. It's pretty weird though cause it remembered the settings of my TV (which famously works with the cursed cables from hell) even after a reinstall. So I'm inclined to believe that's why it didn't solve the monitor issue. However, I have been sent this: discussions.apple.com/thread/7683876?start=40&tstart=0 There seems to be a related bug that Apple won't address (yet). However it's only related to my issue since my internal display works just fine. It's just the same insofar as that their external displays don't work. – tugi Jan 19 '17 at 9:55
  • I really don't want to wipe the hard disk and re-install from scratch cause it hardly seems worth the effort of migrating all of my data/installations/customisations. I've already spent a day of my life on this stupid issue, but it's starting to become personal between me, my macbook and the cables. – tugi Jan 19 '17 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .