9

As you fellow devs can imagine, one of the most irritating things I experience in my daily programming life is this silly noise that Terminal makes every time I enter an invalid key. I've went to System Prefs and turned off all sounds for notifications and yet this same stupid noise that terminal makes keeps on inundating me with notifications that I have entered an invalid key sequence.

Any way of stopping this or is Terminal conspiring against me.

4
  • What program are you interacting with? Different programs have configuration settings to control when they send a BEL to the terminal. If you're using the Bash shell, for example, there's an option—which is on by default—to ring the bell if you try to delete or move the cursor past the start or end of the command line.
    – Chris Page
    Jan 20, 2017 at 19:37
  • When a program sends a BEL (the “bell” character Control-G) to the terminal, Terminal plays the system Alert sound. This is controlled by the systemwide volume and mute settings. You can also specifically control the volume of the Alert sound with: System Preferences > Sound > Sound Effects > Alert volume
    – Chris Page
    Jan 20, 2017 at 19:39
  • Why don't you just turn the volume off? Jul 15, 2020 at 6:18
  • 2
    It would inundate me when I listened to music when I code. Jul 16, 2020 at 14:34

1 Answer 1

11

From Terminal.app's preferences (Terminal menu -> Preferences), go to the "Profile" tab in the top pane, make sure your profile is selected, then click the "Advanced" tab in the right-hand pane. Under the section "Bell" there's an option for "Audible bell" which you should deselect. There's also an option for "Visible bell", which is a very useful alternative.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .