0

I am trying to disable Messages on iOS because it is continuously sending SMSs to a foreign number (doing so wasting my credit).

I disabled Messages and FaceTime from the Settings, but Messages still asks to send SMSs for registration. Where can I disable it?

3

On your iPhone, go to:

Settings > Messages and flip the "iMessage" switch to off.

You will still be able to send and receive regular SMSs, charged by your carrier or included in your monthly plan, but not iMessages. And they will stop trying to activate by sending those SMSs to a number abroad.

See http://osxdaily.com/2014/04/15/disable-imessage-ios/ if you want some screenshots.

If this fails then there's an hick-up with your phone or SIM. In that case, try resetting the "Network settings" (you'll lose all saved WiFi credentials):

Settings > General > Reset > Reset NETWORK SETTINGS and confirm. Be sure to really choose "Network Settings".

After the device restarts you can still do a soft reboot, this usually clears most small issues:

  • with the device turned on and unlocked press and hold the Power Button (top or side, in newer models) and the Home Button (front) together, i.e. at the same time
  • keep holding them for 10 seconds and until the device reboots and you see the white Apple logo on screen. You can then let go off the buttons.

Finally, Apple also posts some troubleshooting, if you want to attempt again to re-enable iMessage in the future, and still come across the same problem: https://support.apple.com/en-ca/HT201422

  • 1
    Thanks I will try it. For now it is working just switching off iMessage and Facetime and rebooting the phone. – gc5 Jan 17 '17 at 17:05
  • Yep, forgot that part! Also disable FaceTime (Settings > FaceTime > flip to "Off") - True! FaceTime will also try to activate in the same way :) – Joe L. Farina Jan 17 '17 at 17:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .